Firefox PHP

Language : French

Posted by notre-planete.info 
Re: Language : French
May 27, 2008 07:39PM
Pour le fichier de langue : il faut le mettre dans le dossier "include" > "lang"

Ensuite la langue peut-être sélectionnée pour le forum, mais pas la partie administration.

Pour le reste : il faut poster dans la partie française du forum
Re: Language : French
September 23, 2008 02:19PM
Fichier français mis à jour pour la version 5.2.8
Vous pouvez vérifier la localisation directement sur mes propres forums :
[www.notre-planete.info]

Updated version of french.php => 5.2.8
You can verifiy the translation on my own forums :
[www.notre-planete.info]

--------------------------------
Christophe, [www.notre-planete.info]
Re: Language : French
March 09, 2009 12:15PM
Version avec le bon "CHARSET" (UTF-8)
Attachments:
open | download - french.php (38.4 KB)
Re: Language : French
April 24, 2012 09:51AM
Bonjour,

En installant la version française sous 5.2.18 j'ai un problème de codage des caractères qui survient. Une idée ?

D'avance merci
Re: Language : French
January 22, 2013 11:59AM
Bonjour, j'ai eu le même problème et j'ai trouvé la solution :
Pour les fichiers de langue il faut utiliser notepad ++ et convertir les fichier en UTF-8 (sans BOM).

Pour certains modules il manque les fichiers de langue, il suffit de créer un fichier "french.php" en traduisant le fichier de langue anglaise et on applique le même chose avec note pad ++ pour convertir en utf-8.

J'ai traduit l'aide pour les BBcode et les smiley en Fr, si besoin je mettrai les fichier à disposition.
Re: Language : French
April 13, 2015 11:51PM
Hello,

I had to move my installation (version 5.1.22) to a new server.
Everything went well except the message texts which appear like that now:
"je voudrai aborder un probl�me qui nous est cher � tous, "La sant�e""
Where all accented characters are replaced by a ? inside a lozenge but the menus are fine.
I have downloaded the French-UTF8 file from this page and in my default settings, I have selected French-UTF-8

Please help me solve this issue.
Re: Language : French
April 14, 2015 12:21AM
Probably the mysql table has the incorrect character set selected. The defaults may have changed from the earlier mysql.

How did you create the tables, and import the data?
Re: Language : French
April 14, 2015 02:06AM
Hello,

I backed up the database and copied it to the new server with cpanel.
I see now the defaults collation in the database are Latin1_swedish_ci.
What should I do?
Re: Language : French
April 14, 2015 05:30AM
I assume you have a copy of the file you can gunzip, and open in a text editor.
Look to see what character set was was specified on export.
Was it correct ?
Does it differ from Latin1?

You could try "alter table" to change the character set in the existing table. I change the create table statement in the dump/backup file to use the character set I want.




I used cpanel and dumped two databases. Both dumps showed the character set used when the table was created.
--
-- Table structure for table `lcc_dnschecks`
--

DROP TABLE IF EXISTS `lcc_dnschecks`;
/*!40101 SET @saved_cs_client     = @@character_set_client */;
/*!40101 SET character_set_client = utf8 */;
CREATE TABLE `lcc_dnschecks` (
  `dnsid` smallint(5) unsigned NOT NULL,
  `checkid` smallint(5) unsigned NOT NULL
) ENGINE=MyISAM DEFAULT CHARSET=latin1;
/*!40101 SET character_set_client = @saved_cs_client */;

DROP TABLE IF EXISTS `phorum5214_banlists`;
/*!40101 SET @saved_cs_client     = @@character_set_client */;
/*!40101 SET character_set_client = utf8 */;
CREATE TABLE `phorum5214_banlists` (
  `id` int(10) unsigned NOT NULL AUTO_INCREMENT,
  `forum_id` int(10) unsigned NOT NULL DEFAULT '0',
  `type` tinyint(4) NOT NULL DEFAULT '0',
  `pcre` tinyint(1) NOT NULL DEFAULT '0',
  `string` varchar(255) NOT NULL DEFAULT '',
  `comments` text NOT NULL,
  PRIMARY KEY (`id`),
  KEY `forum_id` (`forum_id`),
  KEY `string` (`string`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;
/*!40101 SET character_set_client = @saved_cs_client */;
Re: Language : French
April 14, 2015 05:45AM
A search indicates the original character set was
Quote

No, Phorum was ISO-8859-1 in 5.1 and probably US-ASCII before that. But, UTF-8 has become the defacto standard for the internet.
from this topic [www.phorum.org]
Sorry, only registered users may post in this forum.

Click here to login