Firefox PHP

embed_images breaks bbcode

Posted by salmobytes 
embed_images breaks bbcode
April 08, 2017 05:17PM

BBcode (version 2.0.12)

Embed Images (version 1.1.5)

VD server
Linux 2.6.32-042stab093.4 #1 SMP Mon Aug 11 18:47:39 MSK 2014 x86_64 x86_64 x86_64 GNU/Linux

BBcode works fine by itself. I can make [img] posts pointing to images manually uploaded to my own server. Presumably to external servers as well.

But when I turn on Embed_Images existing BBcode image links stop working. I fiddled with settings as best I could. This is a new installation on a new server. All of this had worked for years on an older VD server that lost CentOS support (so I had to move to a new server).

Edited 5 time(s). Last edit at 04/08/2017 06:24PM by salmobytes.
Re: embed_images breaks bbcode
April 09, 2017 02:18PM
Oh well
Re: embed_images breaks bbcode
April 09, 2017 04:43PM
>> But when I turn on Embed_Images existing BBcode image links stop working. <<
If you upload a new image, with Embed_Images enabled, does the link work?
Look at the embedded link with Embed_Images on and off, does it change?

Check the cache directory for photos exists, and is read write.
Check the web server log(s).
Check the php log.

Are you using the "Store Files On Disk" mod?
Re: embed_images breaks bbcode
April 10, 2017 12:57AM
Good tips.
Don't know why I didn't think of the apache log.

It was a file permissions issue. 775 on the Upload directory fixed it.

However, it is interesting to note this ONLY became an issue when Embed_Images was On (that BBCode links to existing, manually uploaded images broke). With 555 file permissions BBCode worked when Embed_Images was off, broke when it was on.

With 775 permissions both work.

I'll have to try 755 permissions. Would it be the group permission? I'll find out.

Thank you. I needed a direction and you gave it.

Edited 3 time(s). Last edit at 04/10/2017 01:27AM by salmobytes.
Sorry, only registered users may post in this forum.

Click here to login