Firefox PHP

Module: External Phorummail

Posted by Thomas Seifert 
Re: Module: External Phorummail - BUG: HTML email from AOL
July 09, 2010 01:12PM
Thank you, yeah, I've got the mails.
Give me the weekend to work my way through this please.


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Module: External Phorummail
July 11, 2010 07:41PM
Attached new version 2.1.2 which should fix these issues. Thanks to Robert Angle for the detailed testcases.
Also ezComponents were upgraded.


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Module: External Phorummail
July 15, 2010 07:13AM
And thank you for the bug fixed Thomas. Your work here and that of the rest of the phorum dev team is very much appreciated!


Robert Angle
Phorum lover, nothing more.
Ruminations
Re: Module: External Phorummail
August 06, 2010 09:24AM
Hi Thomas,

today the post in the proper thread, I want to use a gmail account to import mail from it. But when I execute script.php, I get an error message:

activequant:/var/temp/phpBB2# /usr/bin/php ./script.php --scheduled

Fatal error: Uncaught exception 'ezcMailTransportException' with message 'An error occured while sending or receiving mail. Could not read from the stream. It was probably terminated by the host.' in /var/temp/phpBB2/mods/ext_phorummail/ezc/Mail/src/transports/transport_connection.php:218
Stack trace:
#0 /var/temp/phpBB2/mods/ext_phorummail/ezc/Mail/src/transports/pop3/pop3_transport.php(207): ezcMailTransportConnection->getLine()
#1 /var/temp/phpBB2/mods/ext_phorummail/ext_phorummail.php(65): ezcMailPop3Transport->__construct('pop.gmail.com', NULL, Object(ezcMailPop3TransportOptions))
#2 [internal function]: phorum_ext_phorummail_scheduled()
#3 /var/temp/phpBB2/common.php(1693): call_user_func('phorum_ext_phor...')
#4 /var/temp/phpBB2/script.php(248): phorum_hook('scheduled')
#5 {main}
  thrown in /var/temp/phpBB2/mods/ext_phorummail/ezc/Mail/src/transports/transport_connection.php on line 218
activequant:/var/temp/phpBB2#

My settings are:
SSL : on/off - doesn't matter, same error message
connection type: pop3
hostname: pop.gmail.com
username: ulrichstaudinger2@gmail.com
password: *****


Do you have an idea what could be wrong?

Cheers



Edited 1 time(s). Last edit at 08/06/2010 09:24AM by chicago5.
Re: Module: External Phorummail
August 06, 2010 09:35AM
Is the module telling that "(OpenSSL extension is installed.)" ?
Googlemail *requires* SSL on.


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Module: External Phorummail
September 06, 2010 02:41PM
Hi, I get this error with 2.1.2

root@xxxxxx httpdocs]# /usr/bin/php ./script.php --scheduled
PHP Fatal error: Call to undefined function phorum_api_user_access_allowed() in /var/www/vhosts/xxxxxxx.com/subdomains/foro/httpdocs/mods/ext_phorummail/ext_phorummail.php on line 255

Some idea?



Edited 1 time(s). Last edit at 09/06/2010 02:56PM by Lord_ZealoN.
Re: Module: External Phorummail
September 07, 2010 10:27AM
replace phorum_api_user_access_allowed in line 255 with phorum_api_user_check_access .
I'm not at home right now to do this change but that should help.


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Module: External Phorummail
September 17, 2010 04:07PM
@Thomas Seifert : I was also trying to setup external phorum mail with google account and got the error -

<br /><b>Fatal error</b>: Uncaught exception 'ezcMailTransportException' with message 'An error occured while sending or receiving mail. Failed to connect to the server: pop.gmail.com:110.' in /home/arshainf/public_html/ancientindianastrology.com/group/mods/ext_phorummail/ezc/Mail/src/transports/transport_connection.php:97
Stack trace:
#0 /home/arshainf/public_html/ancientindianastrology.com/group/mods/ext_phorummail/ezc/Mail/src/transports/pop3/pop3_transport.php(206): ezcMailTransportConnection-&gt;__construct('pop.gmail.com', 110, Object(ezcMailPop3TransportOptions))
#1 /home/arshainf/public_html/ancientindianastrology.com/group/mods/ext_phorummail/ext_phorummail.php(65): ezcMailPop3Transport-&gt;__construct('pop.gmail.com', NULL, Object(ezcMailPop3TransportOptions))
#2 /home/arshainf/public_html/ancientindianastrology.com/group/common.php(1693): phorum_ext_phorummail_scheduled()
#3 /home/arshainf/public_html/ancientindianastrology.com/group/script.php(248): phorum_hook('phorum_ext_phor...')
#4 {main}
thrown in <b>/home/arshainf/public_html/ancientindianastrology.com/group/mods/ext_phorummail/ezc/Mail/src/transports/transport_connection.php</b> on line <b>97</b><br />

I am a novice on phorum and was confused by your comment -
Quote
Thomas Seifert
Is the module telling that "(OpenSSL extension is installed.)" ?
Googlemail *requires* SSL on.
Do you mean to say that - "It will not work with gamil"? OR that we can some how enable SSL in gmail/googlemail and make it work?
Please clarify.
Regards,
Sreenadh
Re: Module: External Phorummail
September 17, 2010 04:08PM
Gmail requires SSL to be enabled and you need the OpenSSL extension for PHP enabled to enable SSL in this module. Does that module report that OpenSSL is installed?


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Module: External Phorummail
September 17, 2010 04:17PM
@ Thomas Seifert: Again I am confused with a question, rather than an answer. :(
Quote

Gmail requires SSL to be enabled and you need the OpenSSL extension for PHP enabled to enable SSL in this module. Does that module report that OpenSSL is installed?

* Is it possible for me to enable SSL in my free gmail account? If not - I understand that I cannot use it with my free gmail account. [Please an answer, no questions please - I am not that smart] :(
* When I installed this module in my forum the module does not report anything at all. Everything was fine. I absolutely don't know whether OpenSSL is enabled in the machine (where our forum is hosted) or not. Can you please help me - how can we check whether OpenSSL is enabled in the host computer or not?
Regards,
Sreeandh
Sorry, only registered users may post in this forum.

Click here to login