Firefox PHP

Module: Admin Mass Email

Posted by Joe Curia 
Re: Module: Admin Mass Email
November 03, 2009 07:29PM
Quote
Joe Curia
Quote
Chris Brown
Question... is there a limit of mails to send? I just can send 350 mails instead of 500.

There should be no limit. Are your receiving an error when you try to send 500 emails? Is the module stopping on the page that says 350 of 500 messages sent?

Quote

Other problem I'm having since the first time I installed this mod is that.. I can't send mails just to active members. I always have to send to everyone... but actually the main idea is just send mails to active phorum users right?

If I select condition "active" and send the email, immediately the success message appears. But is so fast that is obvious, no message has been send.

What exactly are you setting as the condition? It should be "active" = 1 (as shown in this screenshot).

This works for me. If this doesn't work for you, please enable the debugging settings and the Event Logging module. You should be able to see which emails would have been sent as well as the conditional code and the list of recipient ids.

Joe, thanks... I didn't know I had to put a "1". I will try it.
Re: Module: Admin Mass Email
November 03, 2009 07:42PM
Yeah! It worked! Thanks...
Re: Module: Admin Mass Email
January 04, 2010 10:38PM
Hi,

I've just upgraded my phorum to 5.2.14 and am getting the following message when ever I try and preview or send

You are accessing the admin after a security timeout.

I posted in the main phorum support area and Maurice replied:

Quote
Maurice
There are probably URLs in the admin interface that need to be constructed using Phorum admin's built-in URL generation function. With the new version, a lot of work was put into making the admin a safer place. Some modules do need an upgrade unfortunately to become compliant with the improved core code.

Please let me know if I can help in anyway with diagnosis or testing of new versions.

Thanks.
Re: Module: Admin Mass Email
January 04, 2010 11:01PM
This issue was addressed in v5.2.1.06 of the module. Please download the latest version and you should be good to go. You may also want to go through and update any other modules you have installed if they have a newer version posted.


Joe Curia (aka Azumandias)
Modules: l0Admin Mass Email00000000l000000Automatic Time Zones000ll.l00000Enhanced Custom Profiles0.00Google Calendar0000l.l000000Post Previews
000000000Admin Security Suite000000000000Check Modules for Upgrades0000External Authentication000000Group Auto-Email00000.00000Private Message Alerts
000000000Attachment Download Counter0000Custom Attachment Icons000ll.ll00Favorite Forums000000.00000Highlighted Search Terms0000Self-Delete Posts Option
000000000Attachment Watermarks0l00000000Custom Language Database00l.l.0Forum Lockdown00000.00000Ignore Forums0000000000000Threaded Tree View
000000000Automatic Message Pruning00.llll.00Easy Color Scheme Manager0l.l00Forum Subscriptions0000lll000Moderated User Group
Templates:lGeneric Integration000000000 0000Simple Rounded000000 00000000Tabbed Emerald
Re: Module: Admin Mass Email
January 07, 2010 07:55PM
Quote
Joe Curia
This issue was addressed in v5.2.1.06 of the module. Please download the latest version and you should be good to go. You may also want to go through and update any other modules you have installed if they have a newer version posted.

Sorry, I miss read the version number when checking if i was running the latest. Applied the upgrade and all is working perfectly again. Thanks for your help.
Re: Module: Admin Mass Email
January 31, 2011 01:10AM
this module seems like a pretty good idea.
am i right in my understanding of it that it sends all the messages within one http request?
depending on server load this might only take a thousand or so before it starts running into trouble.

i like Maurice's idea of creating a queue of them first.
I'd probably put the actual sending mechanism in a cron job.

were there still plans to do it some way like that?
Re: Module: Admin Mass Email
January 31, 2011 01:28AM
rheo,

When I first coded this module I had no access to cron on my webhost so I never programmed that in. I may look at it in the future. However, as of v5.2.1.04, this module does not send all emails in one go. Instead, it sends a number of emails, refreshes the page with a status bar, sends more emails, refreshes, ad nauseam until all the messages have been sent.


Joe Curia (aka Azumandias)
Modules: l0Admin Mass Email00000000l000000Automatic Time Zones000ll.l00000Enhanced Custom Profiles0.00Google Calendar0000l.l000000Post Previews
000000000Admin Security Suite000000000000Check Modules for Upgrades0000External Authentication000000Group Auto-Email00000.00000Private Message Alerts
000000000Attachment Download Counter0000Custom Attachment Icons000ll.ll00Favorite Forums000000.00000Highlighted Search Terms0000Self-Delete Posts Option
000000000Attachment Watermarks0l00000000Custom Language Database00l.l.0Forum Lockdown00000.00000Ignore Forums0000000000000Threaded Tree View
000000000Automatic Message Pruning00.llll.00Easy Color Scheme Manager0l.l00Forum Subscriptions0000lll000Moderated User Group
Templates:lGeneric Integration000000000 0000Simple Rounded000000 00000000Tabbed Emerald
Re: Module: Admin Mass Email
January 31, 2011 05:10AM
ok. cool. sounds like that would work out fine as well.
Re: Module: Admin Mass Email
July 04, 2011 04:32AM
So far, I have used the module to send email to groups. But when I send emails to individual users I get the following logs:

PHP notice: Array to string conversion
Language: PHP
line 79: $testuser = implode(",",$user_info); line 114: $temp_mail_data["mailmessage"] = str_replace("%$key%", $user_info[$key], $temp_mail_data["mailmessage"]); line 115: $temp_mail_data["mailsubject"] = str_replace("%$key%", $user_info[$key], $temp_mail_data["mailsubject"]);

Within the module:
Your message(s) generated the following error(s):
foo_user = Undefined error.
Re: Module: Admin Mass Email
November 28, 2011 11:45PM
Exactly the same symptoms - when sending to individuals/groups. No email(s) send. Anyone could help?
Thanks!



Edited 1 time(s). Last edit at 11/30/2011 09:37PM by bartek.s.
Sorry, only registered users may post in this forum.

Click here to login