Firefox PHP

Module: Admin Mass Email

Posted by Joe Curia 
Re: Module: Admin Mass Email
April 20, 2009 01:38PM
Help!

I'm always using the mass mail to send a MONTHLY newsletter to all users. Since a week ago, I create the mail, send it and in the progress bar, when it gets to the user number 5 of 410. It stops working, and nothing happens.

Any idea? Should I turn off/on the module? Reinstall it?

Thanks!

Christian
Re: Module: Admin Mass Email
April 21, 2009 11:05AM
Sedget: Please redownload and install this module. I have added debugging options to the Edit Settings tab. Please enable the Event Logging module and the debugging for this module and then try to send a test message to yourself. First, choose yourself as recipient. Then try a simple subject/body (such as test/test) and preview it. If a window doesn't pop up with a preview let me know. Then send the email. Please report on all event logs from the Admin Mass Email module. If the test message goes through, please retry your conditions and again report all event logs from the Admin Mass Email related to the new message. Thank you for your patience as we debug this.

Christian: Please also redownload and install this module, enable the Event Logging module and the debugging for this module. I would advise setting it to debug the messages without actually sending them (no need to keep emailing those first 5 users). Then resend your newsletter and report on any event logs from the Admin Mass Email module. My thought is that we are running into a problem with the second set of email addresses (ie the first 5 go, it refreshes, somewhere in 6-10 a problem arises and we halt). Thank you for your patience as we debug this.


Joe Curia (aka Azumandias)
Modules: l0Admin Mass Email00000000l000000Automatic Time Zones000ll.l00000Enhanced Custom Profiles0.00Google Calendar0000l.l000000Post Previews
000000000Admin Security Suite000000000000Check Modules for Upgrades0000External Authentication000000Group Auto-Email00000.00000Private Message Alerts
000000000Attachment Download Counter0000Custom Attachment Icons000ll.ll00Favorite Forums000000.00000Highlighted Search Terms0000Self-Delete Posts Option
000000000Attachment Watermarks0l00000000Custom Language Database00l.l.0Forum Lockdown00000.00000Ignore Forums0000000000000Threaded Tree View
000000000Automatic Message Pruning00.llll.00Easy Color Scheme Manager0l.l00Forum Subscriptions0000lll000Moderated User Group
Templates:lGeneric Integration000000000 0000Simple Rounded000000 00000000Tabbed Emerald




Edited 1 time(s). Last edit at 04/21/2009 11:20AM by Joe Curia.
Re: Module: Admin Mass Email
April 21, 2009 03:18PM
When i send out mails to all 45 members using this module, i get 2 copies to my hotmail account.... and one copy to my yahoo account.

Is there any known issue with hotmail doing this?

Rabarbervin.
Re: Module: Admin Mass Email
April 21, 2009 04:03PM
I have seen no issue with hotmail accounts like this. Can you verify that you are seeing the same user emailed twice? With 45 users, you can check if any in the list have the same email (such as your personal account and your admin account)? This is just one possibility and you may have already checked this.

With the newest upload (done today) of the module you can run a test email in debugging mode without actually having that email go out to the users. Perhaps try this and check the event logs to see if two emails are actually being generated for the hotmail account and if those emails are for the same user/user_id.


Joe Curia (aka Azumandias)
Modules: l0Admin Mass Email00000000l000000Automatic Time Zones000ll.l00000Enhanced Custom Profiles0.00Google Calendar0000l.l000000Post Previews
000000000Admin Security Suite000000000000Check Modules for Upgrades0000External Authentication000000Group Auto-Email00000.00000Private Message Alerts
000000000Attachment Download Counter0000Custom Attachment Icons000ll.ll00Favorite Forums000000.00000Highlighted Search Terms0000Self-Delete Posts Option
000000000Attachment Watermarks0l00000000Custom Language Database00l.l.0Forum Lockdown00000.00000Ignore Forums0000000000000Threaded Tree View
000000000Automatic Message Pruning00.llll.00Easy Color Scheme Manager0l.l00Forum Subscriptions0000lll000Moderated User Group
Templates:lGeneric Integration000000000 0000Simple Rounded000000 00000000Tabbed Emerald
Re: Module: Admin Mass Email
April 21, 2009 06:35PM
Quote
Joe Curia
Sedget: Please redownload and install this module. I have added debugging options to the Edit Settings tab. Please enable the Event Logging module and the debugging for this module and then try to send a test message to yourself. First, choose yourself as recipient. Then try a simple subject/body (such as test/test) and preview it. If a window doesn't pop up with a preview let me know. Then send the email. Please report on all event logs from the Admin Mass Email module. If the test message goes through, please retry your conditions and again report all event logs from the Admin Mass Email related to the new message. Thank you for your patience as we debug this.

Hi Joe,

i've done what you tell me to do., so with selected user test subject and body it works fine and i receive email. event logging tell all about this succes story ;)

now i try with this(see the attached picture please) configuration and i have nothing in event logging, and no mail in my box. I don't understand what's wrong !

Thanks for help.


Re: Module: Admin Mass Email
April 21, 2009 06:52PM
Yep!
You were right... i had forgotten about my admin going to the same adress that my other user...
So no problem with the module or with hotmail.

Thx for helping!
Rabarbervin.
Re: Module: Admin Mass Email
April 21, 2009 10:34PM
Sedget, I have not come close to 7000 posts on my own forum but I have updated the setting in the database to test it and was able to see a test message with that condition set.

Could you try this:
  • Leave recipient at default (send to all)
  • Set subject to "Test"
  • Set the body to "Test post number = %posts%"
  • Select your user from the preview dropdown list and click "Preview"
  • Check that the module is seeing the proper number of posts in the preview message.


Joe Curia (aka Azumandias)
Modules: l0Admin Mass Email00000000l000000Automatic Time Zones000ll.l00000Enhanced Custom Profiles0.00Google Calendar0000l.l000000Post Previews
000000000Admin Security Suite000000000000Check Modules for Upgrades0000External Authentication000000Group Auto-Email00000.00000Private Message Alerts
000000000Attachment Download Counter0000Custom Attachment Icons000ll.ll00Favorite Forums000000.00000Highlighted Search Terms0000Self-Delete Posts Option
000000000Attachment Watermarks0l00000000Custom Language Database00l.l.0Forum Lockdown00000.00000Ignore Forums0000000000000Threaded Tree View
000000000Automatic Message Pruning00.llll.00Easy Color Scheme Manager0l.l00Forum Subscriptions0000lll000Moderated User Group
Templates:lGeneric Integration000000000 0000Simple Rounded000000 00000000Tabbed Emerald
Re: Module: Admin Mass Email
April 29, 2009 02:37PM
Joe,

This looks like a great module - I have an admin asking about something almost the same as this module - he wants to send out a PM to all users in one group.

It looks like this module would easily send e-mail to all users in one group .... How hard do you think it would be to add a "PM-instead" option?

I'm wondering if it could be as simple as replacing the mail() call with a Phorum function call to send a PM - then just have a radio-button option for which method.

Any thoughts from the crowd?

------------------------
Sean Phelan
Sites By Sequoia - Web Marketing ... The Experts at Building Your Success Online
Re: Module: Admin Mass Email
May 05, 2009 03:57AM
hi joe,

sorry for not answering before notification didn't work.

i make the test you ask me it's work

Quote

Could you try this:

* Leave recipient at default (send to all)
* Set subject to "Test"
* Set the body to "Test post number = %posts%"
* Select your user from the preview dropdown list and click "Preview"
* Check that the module is seeing the proper number of posts in the preview message.

Subject:Test

This is a multi-part message in MIME format.

--ame_bndp_1241509808
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Test post number = 7062
--ame_bndp_1241509808--

there's a log event corresponding to this task.


So i didn't understand why i can't use the conditionnal user rules :(
In my case i fill the form with 7000 post because i'm the only one to have so much post. If i put 50 it's the same result forme => not working.
I don't understand to why there's no log event for this failed task.

thanks for help
Re: Module: Admin Mass Email
May 05, 2009 12:37PM
Please upload this new settings.php file to your server and try your conditional send again. You should now see at least one log entry showing the php script that is evaluated to create the list of recipient user_ids. You should also see a list of recipient user_ids. Pleast let me know what you see.

If this doesn't show an obvious solution, I would ask you to PM me with a user/password for an admin on your site and a user/password for FTP access so I can further debug. If you are not comfortable with that, we can keep trying it with messages back and forth on the forum, but I am not too hopeful of that working.


Joe Curia (aka Azumandias)
Modules: l0Admin Mass Email00000000l000000Automatic Time Zones000ll.l00000Enhanced Custom Profiles0.00Google Calendar0000l.l000000Post Previews
000000000Admin Security Suite000000000000Check Modules for Upgrades0000External Authentication000000Group Auto-Email00000.00000Private Message Alerts
000000000Attachment Download Counter0000Custom Attachment Icons000ll.ll00Favorite Forums000000.00000Highlighted Search Terms0000Self-Delete Posts Option
000000000Attachment Watermarks0l00000000Custom Language Database00l.l.0Forum Lockdown00000.00000Ignore Forums0000000000000Threaded Tree View
000000000Automatic Message Pruning00.llll.00Easy Color Scheme Manager0l.l00Forum Subscriptions0000lll000Moderated User Group
Templates:lGeneric Integration000000000 0000Simple Rounded000000 00000000Tabbed Emerald
Sorry, only registered users may post in this forum.

Click here to login