Firefox PHP

Module: User Tagging

Posted by Maurice Makaay 
Re: Module: User Tagging
June 26, 2009 09:42AM
The rules are setup with the Template variable being USERRANK and the HTML code just the text of the level, there is no additional formatting.

The read.tpl contains the following section:

{IF MESSAGES->user->USERRANK}
    <div><strong>Rank:</strong> {MESSAGES->user->USERRANK}</div>
{/IF}
Re: Module: User Tagging
July 06, 2009 10:13PM
Is there anyway of completely un-installing this mod and all of its data so i can re-install it from scratch ??

I've tried find where the post counts are stored for the mod and can see it, I've tried deleting the rows from the phorum_settings table, but no change as yet...
Re: Module: User Tagging
July 16, 2009 08:29PM
The post counts are stored in the custom profile field "mod_user_tagging".
You can remove that field and then recreate it (make sure that you use the exact same field settings).
However, rebuilding the post counts should reset the counters as well.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: User Tagging
October 21, 2009 08:22PM
I'm having an issue with deleting a user tag in the admin mod area. Any help out there? Where does the script post the tags that were created?
Re: Module: User Tagging
October 21, 2009 08:42PM
It would help to describe the issue.


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Module: User Tagging
October 21, 2009 08:48PM
The issue is I can not delete a rule that was setup in this mod. There is the following buttons

Language: HTML
Edit| Copy| Delete

I should be able to select delete and delete that rule. But it doesn't, it goes all the way to "Are you sure you want to delete the rule "Lurker"? " Yes No

I select yes and the rule is still there.
Re: Module: User Tagging
October 21, 2009 09:08PM
What you kind of left out of the story was the fact that you were getting admin timeout warnings in between, right? If you did, then the new 1.0.6 release of the module should fix this issue for you. Otherwise, give it a try anyway. 1.0.6 works for me on Phorum 5.2.13.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: User Tagging
October 21, 2009 09:23PM
Works like a champ thanks
Re: Module: User Tagging
December 03, 2009 11:29PM
Quote
Maurice Makaay
The post counts are stored in the custom profile field "mod_user_tagging".
You can remove that field and then recreate it (make sure that you use the exact same field settings).
However, rebuilding the post counts should reset the counters as well.

Hi Maurice,

I'm still struggling to get this module to work. I have spent some time looking into the code and have found something that I am not sure is correct and would appreciate your input if possible.

EDIT: Sorry, should clarify. The paragraph below relates to the user_tagging_process_rule function.

Within the api.php there is a switch block for the rule scope, for all my rules this is going into the GLOBAL case. However, looking at the following code I would expect $count to return an int and it appears to be returning a character. Incidentally, the character value returned in the $count variable is the same as held in $user['admin'].

Is this correct or is my user table corrupted ??

Thanks, Jon.



Edited 1 time(s). Last edit at 12/03/2009 11:32PM by tankslap.
Re: Module: User Tagging
December 04, 2009 12:54AM
What is the content of $user['admin']? That one should either be 0 (zero) or 1 (one).


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Sorry, only registered users may post in this forum.

Click here to login