Firefox PHP

Module: Embed Images

Posted by Maurice Makaay 
Re: Module: Embed Images
September 04, 2008 04:48AM
Nope that's a different one, the one i'm using is still on that list at #7.
I'm not aware of any xss examples that get past it, if such a beast exists out there i will reconsider my choice of course. I have no probs with the blacklist complaint either, as long as safehtml turns malformed/malicious html into correct html, you're one strip_tags away from your whitelist. Anyway, maybe Maurice will come up with something even better for the core mod, let's see :)

Chris
Re: Module: Embed Images
October 16, 2008 10:02PM
This is a really handy module that is working well for us, perhaps too well.

We have a pretty high setting (800x600) for our forum which works well for most photos. Where it throws things off is in user sigs. A couple users have tried using small images with links to different sites of theirs, but they are not rendered properly because of the module.

Is an option possible to have images below the max width and max height ignored and not processed?

Thank you,

James

Wallet Friendly Watch Forum
www.wf-wf.com
Re: Module: Embed Images
October 16, 2008 10:06PM
Do you have an example? I'm not sure now what "not rendered properly" means.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Embed Images
October 16, 2008 11:10PM
Sorry, of course.

Let's suppose that I want to do a signature similar to yours. Icons for different websites for my blog, this, that, and the other.

So I set up my code with the image file, then the URL and text.

Language: HTML
[IMG]http://img.photobucket.com/albums/v158/jenloe_watches/z-sigs/wordpress.png[/IMG] [URL=http://jitteryjim.com]blog[/URL] | [URL=http://watches.jitteryjim.com]watches[/URL] | [URL=http://watchesinmovies.info]watchesinmovies[/URL] | [IMG]http://img.photobucket.com/albums/v158/jenloe_watches/z-sigs/flickr.png[/IMG] [URL=http://www.flickr.com/photos/jitteryjim/]flickr[/URL] | [IMG]http://img.photobucket.com/albums/v158/jenloe_watches/z-sigs/FaceBook.png[/IMG] [URL=http://www.facebook.com/people/James_Enloe/1033956702]facebook[/URL] | [IMG]http://img.photobucket.com/albums/v158/jenloe_watches/z-sigs/Twitter.png[/IMG] [URL=http://twitter.com/jamesenloe]twitter[/URL]

Then what I end up seeing when I view a post is this:



So rather than placing the images sequentially next to the text, they end up below.

If I take it a different direction and this time put the IMG within the URL, it renders basically the same way, only now some of the text links are broken.

Language: HTML
[URL=http://jitteryjim.com][IMG]http://img.photobucket.com/albums/v158/jenloe_watches/z-sigs/wordpress.png[/IMG] blog[/URL] | [URL=http://watches.jitteryjim.com]watches[/URL] | [URL=http://watchesinmovies.info]watchesinmovies[/URL] | [URL=http://www.flickr.com/photos/jitteryjim/][IMG]http://img.photobucket.com/albums/v158/jenloe_watches/z-sigs/flickr.png[/IMG] flickr[/URL] | [URL=http://www.facebook.com/people/James_Enloe/1033956702][IMG]http://img.photobucket.com/albums/v158/jenloe_watches/z-sigs/FaceBook.png[/IMG] facebook[/URL] | [URL=http://twitter.com/jamesenloe][IMG]http://img.photobucket.com/albums/v158/jenloe_watches/z-sigs/Twitter.png[/IMG] twitter[/URL]

And the result:



Hope that makes sense, and helps.

Thank you,

James

Wallet Friendly Watch Forum
www.wf-wf.com
Re: Module: Embed Images
October 17, 2008 01:38AM
So the problem is not that the images aren't rendered correctly. You are talking about the HTML rendering here. Since your max image size is quite large, you could opt for changing the module's css. In mods/embed_images/templates/emerald/css.tpl you can find some "float: left" styling. If you remove those floats, you might get what you want.

Additionally, you might check this message from this thread in which the same kind of issue is discussed. For the big allowed size this might be less useful though.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Embed Images
October 21, 2008 11:36AM
Sorry I did not post my previous message at the right place and I dont(t known how to destroy it ...


Hello,

with THIS image [perso.club-internet.fr] UGCB1.JPG

embed_images 1.0.8 (Phorum 5.2.9a) returns this error message:

Quote

Image error
HTTP request failed with code $code.
open image URL

Any idea?
Re: Module: Embed Images
October 21, 2008 01:10PM
THere is a space in the name, which is not HTTP compliant. Change that space to %20 and it should work. Now, the URL is recognized as adufaux.club.fr/images/Salon, which results in a 404 error (you can check by clicking on the link in your own message above).

Here the image with %20 in it.




Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Embed Images
October 22, 2008 10:10AM
Search does not return anything about "center image", is it any way to center an image with embed images module without to discard "float: left" from the css?
Re: Module: Embed Images
October 22, 2008 11:42AM
Float left and center are mutually exclusive in my world. Why would you want to use float left in combination with centering?


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Embed Images
October 22, 2008 11:50AM
I know that they are mutually exclusive, I would only like to know whether there exists an easy way to bypass that conflict and to center an image in a message without loosing the benefit of that great module.
Sorry, only registered users may post in this forum.

Click here to login