Firefox PHP

Module: Store Files on Disk

Posted by Maurice Makaay 
Re: Module: Store Files on Disk
July 25, 2009 08:18PM
Quote
Maurice Makaay
Thanks for letting me know!
And a bit *WOOT!* for the new path structure.

Since 5.2.12 is out now and since you seem to be able to run it ("It runs at Bill's, ship it!"), I removed the old version of the module and offer only the new version from this thread from now on.

The backup like the new path and it been running each night without a hiccup.

And no complaints from anyone on any issue of attaching or viewing files in posts since I upgraded the module.

It working good!

Thank you for making this change!
Bill
Re: Module: Store Files on Disk
January 24, 2010 09:19PM
Hi Maurice, Thomas

I have run into a problem with this module with the latest upgrade to 5.2.14. I had previously converted my attachments using 1.0.1 with no problems. I ran the new console_convert with no problems. I have a setup on Xampp on my local computer on which I do all my development and testing. On Xampp everything worked fine. I could view the all the attachments with no problem. When I moved the files to the web-server (I use a Godaddy shared account) I could not view the attachments. When clicking on the open link in the message body, instead of seeing the attactment the following line would appear in the web browser.

[www.t34classic.org]

There were no error messages. When I tried to download the image using the download link in the message I got an empty jpg file. Thinking that the attachments had not loaded correctly I downloaded the image from the sites file manager and it opened fine showing the image I should have seen when working from the message links. Next I checked the relative address of the attachment folder. I went to the store_files_on_disk module and re-entered the path and saved the setup with no errors. When I retried the link from the message is still got the same result. Next I went back and reloaded all the files for Xampp to the web server, checked all the config files, and still got the same result.

I have not changed anything in the control panels since the upgrade except adding the new store files to disk. My guess is that I have not set the proper folder/file permissions on the attachments folder, currently 755/644. I am not sure where to go from here.

Any ideas or suggestions would be appreciated.

The Phorum installation is wrapped in Joomla. I have also tried to view the link from within the Phorum control panel by opening the Phorum Index with the same results.

My account at Godaddy uses PHP 5.2.5 and MySql 5.x

Thanks,
Tom
Re: Module: Store Files on Disk
January 24, 2010 09:42PM
Godaddy never worked well for phorum users.
What version did you upgrade from? what else changed? did you just move to godaddy?


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Module: Store Files on Disk
January 25, 2010 01:49AM
I upgraded from Phorum 5.2.10, I also went from Joomla 1.5.14 to joomla 1.5.15. Have been on Godaddy for two years. The only change other that than the upgrades was to do the upgrade to store_files_on_disk 1.1.0. I had it all working fine using Xampp.
Re: Module: Store Files on Disk
January 25, 2010 05:31PM
The error is related to the setting "Allow Linking To Uploaded Files" on the General Settings screen in the admin. Try playing with that one.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Store Files on Disk
January 26, 2010 01:49AM
I tired all three settings with no luck, both from the Phorum admin panel Phorum Index, and from the Joomla website. The results were the same, like the link above. I tried it for several different attachments.
Re: Module: Store Files on Disk
April 22, 2010 06:48AM
Hello,

I have been using this module for some time with phorum 5.2.13 and it worked smooth and great.
But my server was hacked and I had to rebuild with backups.
The problem is that now, no image is showing even though the folder is there.
What am I missing?
Thanks
Re: Module: Store Files on Disk
April 22, 2010 08:19AM
no permissions? no database entries? or you didn't enable the module.


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Module: Store Files on Disk
April 22, 2010 09:49AM
I'm guessing the permissions part. Just uploading a new tree doesn't make things fully work. The directory, subdirectories and all files in it need to be readable and writable by the web server.

Another suspect would be the file storage path. If the server was exactly reconstructed or if the storage path was configured as a relative path, this should not be a problem. But if you used an absolute path, it could be that the new storage path differs from the original one. In that case, you'll have to update the module's settings.

You could check what happens when you upload a new attachment to a message. If the file contents end up in the files database, then it's clear that the webserver is unable to access the file storage directory. You can check the database to see if that happens: the file_data field will be filled in that case.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Store Files on Disk
April 22, 2010 09:28PM
Hello,

Thanks for your replies.
I checked on all your questions:
- Module is correctly enabled.
- Absolute path of the folder: nothing has changed
- Permissions on the folder are read-write
- I uploaded a new picture and verified that it went correctly to the directory (and not in the file_data field) and it is displaying correctly
Still all previous pictures are not displaying
The only point I just found out is that PHP and mysql were upgraded: could that be a factor?
Sorry, only registered users may post in this forum.

Click here to login