Firefox PHP

Module: User Avatar

Posted by Maurice Makaay 
Re: Avatars not available for LIST template?
August 09, 2010 10:52PM
Alright. I just added "hook: list|mod_user_avatar_read" to the module's "info.txt" file and it seems to work fine for the list template.
Re: Avatars not available for LIST template?
August 09, 2010 10:53PM
Alright. I added
Language: PHP
hook: list|mod_user_avatar_read
to "info.txt" and it seems to work fine now.
Re: Module: User Avatar
September 21, 2010 09:15PM
@Thomas Seifert: I am facing some problem with the User Avatar Module (same issue I am facing with Mood module as well). After enabling the module, and configuring the templates, I am getting the option to configure in the user control panel, but in the thread the user avatar photo is not appearing! (Same is the case with Mood module as well). But in the user profile page the user avatar is appearing without any issue! Note that the user avatar is selected, and "Do not display avatars in postings" is UNchecked in user control panel. The forum version I am using is 5.2.15a. For our phorum for all forums the default "List view" is set to "Flat" and "Read view" "Threaded"; I don't know whether it has any effect on the mood and user Avatar images not getting displayed or not.
Please help.
Regards,
Sreenadh
Re: Module: User Avatar
September 21, 2010 09:26PM
As Maurice told you in another thread, you are probably editing the wrong template in that case.
Which template are you using?
Which *exact* files did you modify in which way?


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Module: User Avatar
September 21, 2010 09:51PM
I am using the Emarald Template. I have modified -
1) read.tpl
2) read_hybrid.tpl
3) read_threads.tbl
4) profile.tpl
All as suggested. In control panel I am getting the settings for uploading the user avatar, in profile page I am able to see the user avatar. But no-where else it is appearing.

In both read.tpl and read_hybrid.tpl, I have added the following code as suggested.
Language: HTML
<td style="padding-right:10px"> {IF MESSAGES->user_avatar} <img src="{MESSAGES->user_avatar}" alt="avatar" {IF MESSAGES->user_avatar_w} style="width:{MESSAGES->user_avatar_w}px; height:{MESSAGES->user_avatar_h}px" {/IF} /> {/IF} </td>
In read_threads.tbl, I have added the following code -
Language: HTML
<td style="padding-right:10px"> {IF MESSAGE->user_avatar} <img src="{MESSAGE->user_avatar}" alt="avatar" {IF MESSAGE->user_avatar_w} style="width:{MESSAGE->user_avatar_w}px; height:{MESSAGE->user_avatar_h}px" {/IF} /> {/IF} </td>

In profile.tpl, I have added the following code -
Language: HTML
{IF PROFILE->user_avatar} <img src="{PROFILE->user_avatar}" alt="avatar" {IF PROFILE->user_avatar_w} style="width:{PROFILE->user_avatar_w}px; height:{PROFILE->user_avatar_h}px" {/IF} align="right" /> {/IF}
I hope I am not doing anything wrong in any of the above sections.
Regards,
Sreenadh
Re: Module: User Avatar
September 22, 2010 10:14AM
Hi,
Since I have set the "List view" as "Flat" and "Read View" as "Threaded" the template used for me would be "read_hybrid.tpl" I hope. I am attaching the modified template along with. If I am committing any mistake anywhere in it related to the required User Avatar template changes please correct me. Please note that even after all these changes done, the User Avatar is NOT getting displayed.
Regards,
Sreenadh
Attachments:
open | download - read_hybrid.tpl (7.4 KB)
Re: Module: User Avatar
September 22, 2010 10:29AM
That would be read_threads.tpl. Hybrid view is only used if Read View is selected as hybrid.
You really have the Emerald template selected and are modifying the templates/emerald/*.tpl files? No copy of the template as it would be recommeneded? Which modules are you using together with that? Some are providing their own read*-templates.


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Module: User Avatar
September 22, 2010 11:23AM
Hi,
I was reading through the previous messages in this thread. It seems that meany such as Sheldon, Lammi etc too had the same problem. For Sheldon the problem seems to have got corrected some how, I tried the things he did - but still nothing worked for me till now!

1) I am Using Emarald template for sure and nothing else. (No copy nothing)
2) I am using many modules such as - "Admin Mass Email, Admin Security Suite, Admin Skins, AJAX Mark Read, Attachment Download Counter, Attachment Uploader, Auto Hide, Automatic Time Zones, BBcode - 2.0, BBCode Vedio, Bulk PM, Check Modules for Upgrades, Delete Myself Mod, Email Auth, Embed Attachments, Embed Mp3, Embed Images, Event Logging, External Phorummail, File List, Group Auto-Email, Guitar TAB, Hide Edit Notification, HTML in Messages (version 3.0.0), Impersonate User, Limit threaded views, Make Profiles Private, Meta Description, New Count, Online Users, PDF Pages, M Keep Copy enabled by default, Post Previews, Pre-Approved Posters Module, Private Message System Restriction Control, Quick Reply, Rate This Thread, Recent Messages, Registration notification, Remember Username, Smileys, Static Pages, Threaded Tree View, Top Users, Topic Poll, Username Restrictions" - ON and working. Other modules are set to off. To be true, I am using almost every phorum module that is compatible with 5.2.15a.
And currently I am struggling to get User Avatar, User Mood, User Thank/Flame, Move messages etc working.

Note: We were using a Yahoo Group, and yahoo is planning to remodel Yahoo groups and we would be losing most of our favorite functionality. I was searching for something which could at least provide something near to Yahoo groups and that is how I found Phorum. Actually except WYSIWYG Editor and archive option almost everything (and may be much more) is possible with Phorum it seems. The Phorum External mail module was a life saver regarding mailing messages to phorum. So in truth I want to use and implement EVERYTHING that is possible through available phorum modules. We have a 3000+ user group in Yahoo at [groups.yahoo.com] and once our phorum is ready at [www.ancientindianastrology.com] we plan to migrate all our 3000+ users to this phorum implementation. That is our core purpose behind this effort.

Regards,
Sreeandh
Re: Module: User Avatar
September 22, 2010 12:55PM
A quick comment on 1) Don't do it that way then. The recommended way (see docs/creating_templates.txt) is to create your own copy of the template and edit that one. That way, you can safely install a new version of Phorum, without risking overwriting your modified template files.

You are using the Threaded Tree View module. That module provides its own templates for list and read pages. Decide if you really need the module. If yes, then edit the templates for the module in mods/treeview/templates/<yourtemplatename>/*.tpl. Otherwise, remove the module and you'll be seeing the changes that you applied to your main template files.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: User Avatar
September 22, 2010 01:18PM
Dear Thomas Seifert,
//Which modules are you using together with that? Some are providing their own read*-templates//
Which are these modules which has their own read* templates? May be that could be a cause, since even after modifying the normal read* templates with some minor texts such as <td><h1>Hai<h1></td> in some places where the avatar is expected to appear, when I update the files and view the forum, I am unable to find that extra <td> tag or its contents in the forum! I checked using firebug and confirmed that the modifications I am making to these templates are not appearing there! And I notice that the modules for which I edited the read* modules are - Note bar, Move messages, Moods and Avatar; NONE of them is working!
I am NOT knowingly using any other read* template, but yes, some other module read* template might be over riding the default read* emerald template files! Which could be this problem causing module with its own read* templates?
Regards,
Sreenadh
Sorry, only registered users may post in this forum.

Click here to login