Firefox PHP

Module: Google Maps

Posted by Maurice Makaay 
Re: Module: Google Maps
April 17, 2011 08:13PM
What a "fun". I'm running MSIE9 here and the points are plotting fine for me. Looks like I have to setup an MSIE8 too, so I can test this bit. Edit: nice, found out that the developer tools in MSIE9 can switch the browser to MSIE8 mode and voila, no markers for me either! Test case accomplished, painstaking debug work starting ... :-/

Did you get my edit of my previous message? You might have replied while I was editing that message (about the <enter> / click submit handling)


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce



Edited 1 time(s). Last edit at 04/17/2011 08:18PM by Maurice Makaay.
Re: Module: Google Maps
April 17, 2011 08:23PM
Quote
Maurice Makaay
Did you get my edit of my previous message? You might have replied while I was editing that message (about the <enter> / click submit handling)

We were posting simultaneously.

I uploaded your latest version and the Submit handling issue is now resolved. Enter submits to the "Search Location" button, and one has to manually mouse over "Save Changes". This is good.

Still no plot points. I know I got one IE9 user and I am gonna ask him if he can see them now too.

"Fun" indeed. I have some users reporting that they are using IE7 still.


Robert Angle
Phorum lover, nothing more.
Ruminations
Re: Module: Google Maps
April 18, 2011 12:16AM
I repackaged 2.0.5 with a fix for the usermap addon problem in MSIE8. In my MSIE8, the phorum.org usermap is now showing up.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Google Maps
April 18, 2011 03:49AM
Could you please let me know which files of the module you have modified? Thank you!
Re: Module: Google Maps
April 18, 2011 11:14AM
No, sorry. All kinds of files changed and were added while building the new version of the module and I did not track which ones.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Google Maps
April 18, 2011 01:06PM
Quote
Maurice Makaay
No, sorry. All kinds of files changed and were added while building the new version of the module and I did not track which ones.

Thanks for all your hard work. The plot points are now showing up for me in IE8 as well.

I still have an issue with IE not stretching the map across the full width of the page, whereas it works in all other browsers, but I understand that this is not module related - just IE being finicky.

Thanks again!


Robert Angle
Phorum lover, nothing more.
Ruminations
Re: Module: Google Maps
April 18, 2011 02:02PM
Sorry, the usermap still won't work with IE8. Only the world map shows up.

Webpage error details for module=google_maps,addon=usermap

User Agent: Mozilla/4.0 (compatible; MSIE 8.0)
Message: Unknown runtime error
Line: 394
Char: 197
Code: 0



Edited 2 time(s). Last edit at 04/18/2011 02:27PM by korsakov.
Re: Module: Google Maps
April 18, 2011 02:42PM
That contradicts Robert's and my experience. Are you testing with a fully clean install of the Google Maps module? Have you tried viewing the user map on phorum.org? Does that one not work for you either?


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Google Maps
April 18, 2011 02:55PM
Quote
Maurice Makaay
That contradicts Robert's and my experience. Are you testing with a fully clean install of the Google Maps module? Have you tried viewing the user map on phorum.org? Does that one not work for you either?

I would do as suggested. Each time I uploaded a test release, I completely deleted the directory /mods/google-maps/ (except for my custom template) and uploaded all fresh files.


Robert Angle
Phorum lover, nothing more.
Ruminations
Re: Module: Google Maps
April 18, 2011 03:05PM
Thanks,I just found the link to the Usermap. Yes, it works. Mh, wonder why it breaks for me.
Sorry, only registered users may post in this forum.

Click here to login