Firefox PHP

Module: Google Maps

Posted by Maurice Makaay 
Re: Module: Google Maps
March 07, 2011 04:29PM
I found the problem and fixed it.

The code to put in the read*.tpl should be

Language: HTML
{IF MESSAGES->user->city} {MESSAGES->user->city}, {MESSAGES->user->country} {/IF}

(use 'MESSAGE' for read_threads.tpl)
Re: Module: Google Maps
March 07, 2011 11:20PM
Thanks for the documentation fix!
I updated the README file and re-released version 2.0.3.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Google Maps
April 01, 2011 12:33PM
I released version 2.0.4 of the module.

This release fixes a bug that caused the map in the control center to show the previous map state instead of the new one, after saving the data. The data was correctly stored, but the map did not show the new state.

I also changed the module to present a separate "Location" panel, instead of putting the location map on the user data panel in the control center. The map interface is so big, that it deserves a separate panel.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Google Maps
April 16, 2011 07:38AM
Quote
Maurice Makaay
I released version 2.0.4 of the module.

If you have a custom template at mods/google_maps/tempaltes/{yourtemplatename} and then upgrade to version 2.0.4 of this module, your users Control Panel will crash and write an error report to the event log.

The reason is that there are some new files in the default emerald template that will need to be copied over to your custom template.

Even having copied all them over, I am still getting this message when I click "Location" in the Control Center...

Fatal error: Call to undefined function phorum_api_url() in /forum/mods/google_maps/google_maps.php on line 82


Robert Angle
Phorum lover, nothing more.
Ruminations
Re: Module: Google Maps
April 16, 2011 07:40AM
Quote
Robert Angle
Fatal error: Call to undefined function phorum_api_url() in /forum/mods/google_maps/google_maps.php on line 82

I get this error even if I delete my custom template directory so that the module defaults to emerald.


Robert Angle
Phorum lover, nothing more.
Ruminations
Re: Module: Google Maps
April 16, 2011 12:59PM
Oh, sorry, phorum_api_url() is a call from the Phorum 5.3 API. I'm dabbing around in 5.3 so much lately, that it slipped my mind that it is not available in 5.2.

I have updated the module and repackaged the code. If you try the new archive, it should work.
I also added a note about the module template upgrade to the README.

Thanks for the report, Robert.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Google Maps
April 16, 2011 08:42PM
Thanks. I'll be downloading and trying it in a moment.

I already have a custom profile field called "location". I haven't investigated just how this module is saving a users location, but is there a way to get the Google Map to use my custom field "location" by default if the user hasn't adjusted his Google Map Module setting?

The reason being, is that I would like to add this feature so we can see where everyone is from, without having to ask 800+ users to visit their Control Center and click the Google Map panel and add their location a 2nd time.


Robert Angle
Phorum lover, nothing more.
Ruminations
Re: Module: Google Maps
April 16, 2011 08:57PM
Hmmm.... I don't see a real short cut for doing that. I would write a separate conversion script, which would try to use Google's API's for searching the user location based on what they entered now in their location field. Using that data, the Google Maps module's data could be filled for the user.

Without a full data conversion, a minimal approach could be to display the google map in the user's profile when available. When not available, the location data could be shown instead. Users would still have to visit their control center to get the map going for them.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Google Maps
April 17, 2011 01:39AM
I have downloaded this, made my template configurations, and went live with this.

Internet Explorer users are having trouble getting this to work. The "Search Location" does not bring any results, and viewing the community map either shows a blank space where the map should be, or a world map with NO markers for the users.

In Firefox, Chrome, and Safari everything it working fine.


Robert Angle
Phorum lover, nothing more.
Ruminations
Re: Module: Google Maps
April 17, 2011 01:46AM
Great .. only 25% of the browsers have an issue ;-) I'll try to find the issue. If you have additional input (MSIE versions affected, any error messages, a fix :-) I'd be interested in that. I'll first have to bring up a windows system here, so I can test on MSIE myself.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Sorry, only registered users may post in this forum.

Click here to login