Firefox PHP

Module: Go To Topic

Posted by Maurice Makaay 
Re: Module: Go To Topic
September 10, 2008 04:28AM
Not a big deal, but I noticed the info.txt does not contain a url to this post. This mod was flagged as updated in my CMU mod but I couldn't jump straight to this post to get the update as no url was available.


Joe Curia (aka Azumandias)
Modules: l0Admin Mass Email00000000l000000Automatic Time Zones000ll.l00000Enhanced Custom Profiles0.00Google Calendar0000l.l000000Post Previews
000000000Admin Security Suite000000000000Check Modules for Upgrades0000External Authentication000000Group Auto-Email00000.00000Private Message Alerts
000000000Attachment Download Counter0000Custom Attachment Icons000ll.ll00Favorite Forums000000.00000Highlighted Search Terms0000Self-Delete Posts Option
000000000Attachment Watermarks0l00000000Custom Language Database00l.l.0Forum Lockdown00000.00000Ignore Forums0000000000000Threaded Tree View
000000000Automatic Message Pruning00.llll.00Easy Color Scheme Manager0l.l00Forum Subscriptions0000lll000Moderated User Group
Templates:lGeneric Integration000000000 0000Simple Rounded000000 00000000Tabbed Emerald
Re: Module: Go To Topic
September 10, 2008 09:05AM
I updated the module package's info.txt with a URL.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Module: GO_TO_TOPIC - please note that there is a syntax error in the instructions >>>
November 18, 2009 09:09AM
on how to modify the list.tpl and the list_threads.tpl.

The original README says:

- If you want your browser to jump down the page to the thread from
which you are returning on the message list page, then edit
list.tpl and list_threads.tpl and find:

<a href="{MESSAGES->URL->READ}"

Replace that code with:

<a name="msg-{MESSAGES->message_id} href="{MESSAGES->URL->READ}"

Without this code change, Phorum will jump to the correct list page,
but the page will not scroll down to the message that you are returning
from.


There is a little syntax error, a missing quotation mark. Here is the correct form for the code replacement:

<a name="msg-{MESSAGES->message_id}" href="{MESSAGES->URL->READ}"

Without that quotation mark after the message_id curly bracket, the Phorum main page does not display correctly. You can see the topics, but they do not appear as links



Edited 1 time(s). Last edit at 11/18/2009 09:22AM by Reto.
Re: Module: GO_TO_TOPIC - please note that there is a syntax error in the instructions >>>
November 18, 2009 10:05AM
Thanks for the report. I updated the module package with this fix.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Thank you Maurice, that was fast
November 19, 2009 07:14AM
Re: Module: Go To Topic
September 20, 2010 05:49PM
Hi,
Even after doing all the said changes the "Go To Topic" link is not appearing appearing for me in the read page. Can someone help please. I am using phorum 5.2.15a.
Regards,
Sreenadh
Re: Module: Go To Topic
September 20, 2010 11:05PM
What exactly did you do?
What exact file or files did you edit?

When following the README, this should not be to hard. Simply add the "<a href="{GO_TO_TOPIC_URL}">{GO_TO_TOPIC}</a>" code at an appropriate spot in the read.tpl, read_hybrid.tpl and read_threads.tpl.

If the link is not appearing after doing this, you probably have edited the wrong template files (maybe one from another directory than the template that you are using).


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Go To Topic
September 21, 2010 10:21PM
Hi,
Thanks for the guidance. I am using Emarald Template. I have added, the following line in read.tpl, read_hybrid.tpl and read_threads.tpl
Language: HTML
<a href="{GO_TO_TOPIC_URL}">{GO_TO_TOPIC}</a>
And the following line in list.tpl and list_threads.tpl
Language: HTML
<a name="msg-{MESSAGES->message_id}" href="{MESSAGES->URL->READ}" class="{newclass}" title="{title}">{MESSAGES->subject}</a>
But nothing happened. These links are not appearing anywhere. I am not editing the wrong template for sure, because I am enabling many modules and making corresponding changes as told in the template files and all of them are working fine. Go_To_Topic, User_Avatar, User Thak/Flame, Mood etc are last in my list related which I am getting problems. Almost all other modules are working fine for me as of now.
Am I doing any mistake in the above section?
Regards,
Sreenadh
Re: Module: Go To Topic
January 21, 2011 12:07AM
I released version 1.2.1 of this module.

This release fixes redirection when coming from a sticky thread. Without the fix, the module redirected to the page on which the sticky message had been when it had been unsticky. Now, when returning from a sticky message, the first page is always loaded.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Go To Topic
August 31, 2016 02:24PM
New version:

2016-08-31 v1.2.3 by Oliver Riesen-Mallmann <oliver@riesen.org>
    - Made XHTML 1.0 Transitional compliant.


Using Phorum since 7/2000: forum.langzeittest.de (actual version 5.2.23)
Modules "Made in Germany" for version 5.2: Author_as_Sender, CarCost, Close_Topic, Conceal_Message_Timestamp,
Format_Email, Index_Structure, Mailing_List, Pervasive_Forum, Spritmonitor, Terms_of_Service and German_Language_Files_Package.
Sorry, only registered users may post in this forum.

Click here to login