Firefox PHP

Module: Easy Color Scheme Manager

Posted by Joe Curia 
Easy Color Scheme Manager
September 18, 2008 05:51AM
When you open Easy Color Scheme Manager, there are grids that show all of the backgrounds, borders, etc., and they are listed by their name, and what color they are before any editing. Is there anything to show where these names are on the template when you view it. Default_Font_Color is an easy one to find, but where or what is a Post_Moderation_Background_Color, or a Breadcrum_Border_Color? Is my only option to just change something and then look to see what was changed?
Re: Easy Color Scheme Manager
September 18, 2008 06:44AM
These questions are best asked in the thread for the individual mod, so don't be suprised if this gets merged onto my ECM mod thread.

Anyways, these variables are used througout the template files. To find a specific variable, you could do a search for it within the .tpl files in your template folder. It may be just as easy to see the changes as you suggested.

Due to the nature of the variables being used in multiple places throughout the template files, I don't know that there will ever be an exact listing of where each variable occurs.


Joe Curia (aka Azumandias)
Modules: l0Admin Mass Email00000000l000000Automatic Time Zones000ll.l00000Enhanced Custom Profiles0.00Google Calendar0000l.l000000Post Previews
000000000Admin Security Suite000000000000Check Modules for Upgrades0000External Authentication000000Group Auto-Email00000.00000Private Message Alerts
000000000Attachment Download Counter0000Custom Attachment Icons000ll.ll00Favorite Forums000000.00000Highlighted Search Terms0000Self-Delete Posts Option
000000000Attachment Watermarks0l00000000Custom Language Database00l.l.0Forum Lockdown00000.00000Ignore Forums0000000000000Threaded Tree View
000000000Automatic Message Pruning00.llll.00Easy Color Scheme Manager0l.l00Forum Subscriptions0000lll000Moderated User Group
Templates:lGeneric Integration000000000 0000Simple Rounded000000 00000000Tabbed Emerald
Re: Easy Color Scheme Manager
September 18, 2008 02:17PM
Thanks for the quick response, I appreciated it.
Re: Module: Easy Color Scheme Manager
October 31, 2008 07:20PM
Sorry, but what does "You will not be able to create background images properly as there were no default images from which to establish dimensions" mean? What do I do to resolve this please?
I've searched for this error but couldn't find any more info.

Apart from this minor hiccup, the module seems very useful, thank you!

/\dam

--
My notable Phorum sites:
Movie Deaths Database - "review comments" system mostly powered by Phorum
Learn Chinese! - integrated forum quiz
Re: Module: Easy Color Scheme Manager
October 31, 2008 07:27PM
That error is given if the module is unable to create the necessary images (the gradient bars and the gradient message background). It comes up if you do not have those images available in your template or if you do not have the necessary GD support enabled for PHP. The color schemes you create will work, but you will have to add your own gradient images (or remove them and use solid colors set in the module).


Joe Curia (aka Azumandias)
Modules: l0Admin Mass Email00000000l000000Automatic Time Zones000ll.l00000Enhanced Custom Profiles0.00Google Calendar0000l.l000000Post Previews
000000000Admin Security Suite000000000000Check Modules for Upgrades0000External Authentication000000Group Auto-Email00000.00000Private Message Alerts
000000000Attachment Download Counter0000Custom Attachment Icons000ll.ll00Favorite Forums000000.00000Highlighted Search Terms0000Self-Delete Posts Option
000000000Attachment Watermarks0l00000000Custom Language Database00l.l.0Forum Lockdown00000.00000Ignore Forums0000000000000Threaded Tree View
000000000Automatic Message Pruning00.llll.00Easy Color Scheme Manager0l.l00Forum Subscriptions0000lll000Moderated User Group
Templates:lGeneric Integration000000000 0000Simple Rounded000000 00000000Tabbed Emerald




Edited 1 time(s). Last edit at 10/31/2008 07:29PM by Joe Curia.
Re: Module: Easy Color Scheme Manager
October 31, 2008 07:32PM
Thanks for the speedy response!

I have GD enabled on my server, and in fact, your module has created my graphic here:

However, the graphic doesn't show in my phorum, although the colour changes do.

Quote

It comes up if you do not have those images available in your template
How can I check this please? I am running an ever-so-slightly modified Emerald template - no files have been deleted.

Many thanks,

/\dam

--
My notable Phorum sites:
Movie Deaths Database - "review comments" system mostly powered by Phorum
Learn Chinese! - integrated forum quiz
Re: Module: Easy Color Scheme Manager
October 31, 2008 08:01PM
Do you still have the emerald template installed in the emerald folder, or did you rename the folder?


Joe Curia (aka Azumandias)
Modules: l0Admin Mass Email00000000l000000Automatic Time Zones000ll.l00000Enhanced Custom Profiles0.00Google Calendar0000l.l000000Post Previews
000000000Admin Security Suite000000000000Check Modules for Upgrades0000External Authentication000000Group Auto-Email00000.00000Private Message Alerts
000000000Attachment Download Counter0000Custom Attachment Icons000ll.ll00Favorite Forums000000.00000Highlighted Search Terms0000Self-Delete Posts Option
000000000Attachment Watermarks0l00000000Custom Language Database00l.l.0Forum Lockdown00000.00000Ignore Forums0000000000000Threaded Tree View
000000000Automatic Message Pruning00.llll.00Easy Color Scheme Manager0l.l00Forum Subscriptions0000lll000Moderated User Group
Templates:lGeneric Integration000000000 0000Simple Rounded000000 00000000Tabbed Emerald
Re: Module: Easy Color Scheme Manager
October 31, 2008 08:47PM
I copied the whole folder, then renamed the info file. The ECS module seems to recognise it OK and can update its colours.
I've tried wiping the cache too, but the error about default images is still shown.

/\dam

--
My notable Phorum sites:
Movie Deaths Database - "review comments" system mostly powered by Phorum
Learn Chinese! - integrated forum quiz
Re: Module: Easy Color Scheme Manager
October 31, 2008 08:58PM
Hmm, looking at your site, the images should be available to the mod. Try this from the README:
A note for those of you upgrading.  As a last case resort, You may find it easier to 
simply start your color schemes over from scratch if you run into problems.  To do so,
please open the settings for this module then paste the following into your web browsers 
address bar after the page information that is there:
&erase_easy_colorscheme=VERITABLY
The address should look something like:
http://www.yourweb.com/admin.php?module=modsettings&mod=easy_colorscheme&erase_easy_colorscheme=VERITABLY
Now hit ENTER and this will erase all of your color scheme settings.  Please note
this is irreversible so only do this if you have the need.  You can then rebuild
your color schemes and they should work just fine.
I would suggest erasing the images from the mods tmp_images folder as well.

If completely resetting the data doesn't do it, then the only other issue can be that the mod is unable to use the imagecreatefrompng function.


Joe Curia (aka Azumandias)
Modules: l0Admin Mass Email00000000l000000Automatic Time Zones000ll.l00000Enhanced Custom Profiles0.00Google Calendar0000l.l000000Post Previews
000000000Admin Security Suite000000000000Check Modules for Upgrades0000External Authentication000000Group Auto-Email00000.00000Private Message Alerts
000000000Attachment Download Counter0000Custom Attachment Icons000ll.ll00Favorite Forums000000.00000Highlighted Search Terms0000Self-Delete Posts Option
000000000Attachment Watermarks0l00000000Custom Language Database00l.l.0Forum Lockdown00000.00000Ignore Forums0000000000000Threaded Tree View
000000000Automatic Message Pruning00.llll.00Easy Color Scheme Manager0l.l00Forum Subscriptions0000lll000Moderated User Group
Templates:lGeneric Integration000000000 0000Simple Rounded000000 00000000Tabbed Emerald
Re: Module: Easy Color Scheme Manager
November 06, 2008 07:56PM
Sorry for the delay in responding, I haven't had time to revisit this until now.
I tried wiping the settings and redoing everything and it now works. I'm still not sure what the problem was. but many thanks for the help.

/\dam

--
My notable Phorum sites:
Movie Deaths Database - "review comments" system mostly powered by Phorum
Learn Chinese! - integrated forum quiz
Sorry, only registered users may post in this forum.

Click here to login