Firefox PHP
Re: Module: Topic Poll
June 05, 2009 06:25PM
ummm, i am afraid it is not over yet!!! after setting a poll and trying to vote i am getting the following message:

"Possible hack attempt detected. The posted form data was rejected."

Thanks!

Pepe
Re: Module: Topic Poll
June 06, 2009 05:46AM
Quote
nevasport
ummm, i am afraid it is not over yet!!! after setting a poll and trying to vote i am getting the following message:

"Possible hack attempt detected. The posted form data was rejected."

Thanks!

Pepe

Any clues about why am i getting this error when voting?

Thanks

Pepe
Re: Module: Topic Poll
June 06, 2009 06:25AM
Yes, I was already working on a fix. Please try the repackaged 1.0.12 from the first post. The first fix made the admin interface compatible with the new CSRF protection. This second fix also takes care of making the front end script compatible.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Topic Poll
June 06, 2009 09:55AM
Quote
Maurice Makaay
Yes, I was already working on a fix. Please try the repackaged 1.0.12 from the first post. The first fix made the admin interface compatible with the new CSRF protection. This second fix also takes care of making the front end script compatible.

Thanks Maurice, you are the best ;)

Pepe
Re: Module: Topic Poll
June 09, 2009 07:12PM
I just tried this module but got an error:

Tue Jun 09 16:09:50 2009] [error] [client 76.103.236.115] PHP Fatal error: Call to undefined function phorum_check_posting_token() in /var/www/html/yosemi
tenews/forum/mods/topic_poll/topic_poll.php on line 370, referer: [yosemitenews.info]
Re: Module: Topic Poll
June 10, 2009 03:33AM
You are not running the latest version of Phorum apparently. We urge you to do so, since this is a release that has several security enhancements.

I updated the 1.0.12 package from the first message. I changed the code and I think it will now run on Phorum 5.2.10 and before as well as on the recent 5.2.11.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Module: Topic Poll
June 10, 2009 04:33AM
Quote
Maurice Makaay
You are not running the latest version of Phorum apparently.

I was afraid you'd say that.

Quote

We urge you to do so, since this is a release that has several security enhancements.

I intend to to that upgrade. Just haven't got to it yet.

Quote

I updated the 1.0.12 package from the first message. I changed the code and I think it will now run on Phorum 5.2.10 and before as well as on the recent 5.2.11.

Thanks, I give it a try.
Re: Module: Topic Poll
June 10, 2009 06:54PM
Seems to work just great now. Thanks for your help, Maurice!
Re: Module: Topic Poll
July 03, 2009 01:30PM
Hello. I have a problem with mod topic_poll 1.0.12 when both mods topic_poll and smileys are enabled. I have a smiley defined on string :p. The problem is that mod smileys replaces this string with a smiley inside a tag:
<input type="hidden" name="posting_token<img class="mod_smileys_img" src="[example.com]; alt="maurice green" title="maurice green"/>ost" value="07cbfcad145172164921dc59a071e261"/>
instead of correct
<input type="hidden" name="posting_token:post" value="07cbfcad145172164921dc59a071e261"/>

Phorum version 5.2.11
Re: Module: Topic Poll
July 03, 2009 06:19PM
Please try out version 1.0.13 of the module. That one should fix the issue for you. Note the upgrade instructions.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Sorry, only registered users may post in this forum.

Click here to login