Firefox PHP

php 8.0 and mods/spamhurdles/api.php

Posted by rickrich 
php 8.0 and mods/spamhurdles/api.php
December 23, 2020 05:00AM
php 8.0 and mods/spamhurdles/api.php gives me:

<b>Fatal error</b>: Array and string offset access syntax with curly braces is no longer supported in <b>/homepages/29/d89658545/htdocs/geo/forum/mods/spamhurdles/api.php</b> on line <b>694</b><br />

I went back to php 7.4 for the time being.
Re: php 8.0 and mods/spamhurdles/api.php
December 23, 2020 03:04PM
Change the curly braces to [ ]

[www.php.net]

Language: PHP
<?php // Instead of: $array{0}; $array{"key"}; // Write: $array[0]; $array["key"]; ?>
Sorry, only registered users may post in this forum.

Click here to login