Firefox PHP

HELP!! My phorum has dissappeared

Posted by Selam 
HELP!! My phorum has dissappeared
August 20, 2005 02:07AM
Hi,
My phorum (http://www.viroots.com/forum/phorum/list.php?f=8) has totally dissappeared. When I type in the admin extension it automatically logs me in on two seperate computers, and does not give me the option to log-out. It has no previous forums there and everything is gone. Can someone please tell me what happened and how this can be fixed.

Thanks,
Selam
info@igraderecords.com
Re: HELP!! My phorum has dissappeared
August 20, 2005 02:50PM
If you look at your admin, in the rop right corner you will see where it says: Database Connection Failed. For some reason or another, your db is not working.

Brian - Cowboy Ninja Coder - Personal Blog - Twitter
Re: HELP!! My phorum has dissappeared
August 20, 2005 06:38PM
Thanks - i've followed up with our web hosting service and they dont see any database connection failure on their end...any suggestions??

thanks again,
Selam
Re: HELP!! My phorum has dissappeared
August 20, 2005 07:48PM
yes, ask them again.
somehow your database connection has changed, either you entered the wrong connection info or they changed something on their end.


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: HELP!! My phorum has dissappeared
August 22, 2005 05:15PM
I got the phorum back up (it was a problem on our server's side), all the previous messages are gone and when i try to post anything i am prompted with:
Table 'Phorum.forums_bodies' doesn't exist
Insert Into forums_bodies (id, body, thread) values (0, 'We have been having some', 0)Table 'Phorum.forums_bodies' doesn't exist
Update forums_bodies SET thread = id WHERE id = 0Unknown column 'author' in 'field list'
Insert Into forums (id, author, userid, email, datestamp, subject, host, thread, parent, email_reply, approved, msgid) values ('0', 'Selam', '0', 'selam@igraderecords.com', '2005-08-22 11:04:25', 'Technical Difficulties', 'ool-45700177.dyn.optonline.net', '0', '0', '', 'Y', '<1f287d67e2a355394d3d149e7fa484f5.VIROOTSCOMOnlineForum>')Unknown column 'thread' in 'where clause'
UPDATE forums SET modifystamp = 1124723065 WHERE thread = 0

So no one can post and there are no previous messages.Can you please help?
Thanks so much,
Selam

Re: HELP!! My phorum has dissappeared
August 22, 2005 05:26PM
Selam Wrote:
-------------------------------------------------------
> Table 'Phorum.forums_bodies' doesn't exist

That tells all you need to know. You really need to talk to your host about this problem. Either you or them has totally messed up your database.

Brian - Cowboy Ninja Coder - Personal Blog - Twitter
Re: HELP!! My phorum has dissappeared
September 12, 2005 04:23PM
Hello,
I came over to the support forum to see if anybody else had the problem that hit me over the weekend and saw your post.

All my stuff disappeared (39000 posts and nearly 200 registered users) last Friday.

I poked around in the PMA file (mysql) and all the stuff seems to be locked up in there, but for some unknown reason
all permissions for me (or phorum) to access them has been shut off.

I got the support team looking into it, but so far nothing has been fixed, other than getting the rest of the site up. It also took a hit from somewhere Friday and was off and on for a day and a half, something that's never happened in the four years I've been renting space there.

Could be somebody out there is changing mysql settings on us?
Anybody else having this problem out there?

I did run a repair on all tables but no change. I think it's in the mysql someplace,...does this make sense?
I'm not a programmer, just an end user and only guessing.

Tweed
[tweedsblues.net]
Re: HELP!! My phorum has dissappeared
September 12, 2005 04:34PM
sounds like your mysql data is corrupted. Your host should repair the tables. Of course this is just a guess.

Brian - Cowboy Ninja Coder - Personal Blog - Twitter
Re: HELP!! My phorum has dissappeared
September 12, 2005 05:06PM
Yeah, I thought it was the phorum at first, but it's run beautiful since I loaded it up 2 1/2 years ago with no problems other than when I first was trying to set it up and didn't know what I was doing. I came to this board then and got squared away pretty quickly.

Like I said, I don't know a great deal about the php language or mysql, but I can tell when a door's locked and won't open. Selam's problem was so similar to mine I wondered if we'd both been hacked for some bizarre reasons. We both have music based websites it seems. I looked at his forum last nite and see that it's still screwed. Hope my support guys can do something and if they do I'll get word back here as to what they did. (if they'll tell me that is)

Tweed
tweedsblues.net
Re: HELP!! My phorum has dissappeared
September 13, 2005 12:42PM
Support techs finally discovered that the mysql password had been changed or altered, which would make so that the message board could not access the database. They changed it back to the original and everythings cool.

It WAS in mysql database end and now I'm wondering how the password got changed, cause I sure didn't do it! Anyhow, it's running like a fine Timex.


Sorry, you do not have permission to post/reply in this forum.