Firefox PHP

Target=Blank??

Posted by Sham 
Target=Blank??
May 18, 2001 04:12AM
Hi all. Sorry to barge in on the party, but I have a question.

I set up Phorum with hardly any problems (knock on wood) and everything seems to work fine... however I have seen phorum in action on a certain website and when someone posts a href link in a message body (to a url not an image), it always opens the link in a new window. I can't find anywhere to make this happen and i couldnt find a previous message here that said how to do it.

If anyone could help, i would appreciate it.

Also, on the bottom of the text box is a link to "email replies to this thread" but when i did a tester post and clicked that box, i still haven't gotten an email like i do on that other site... anyone help on this one too?

Any help appreciated.

Thanks
Re: Target=Blank??
May 18, 2001 07:57AM
found the hack that worked for the new window deal, but still cant get the "email replies to this thread" thing to work or figure out why my phorum isnt threading third level replies...


Any help would be greatly appreciated cause Im losing hair fast ;)
Re: Target=Blank??
May 18, 2001 09:18AM
ok, im going to bed now because i just dug deep enough to find out that it wont send email replies to the same email address that the original post was made with. Makes perfect since because why would you need an email of somethgin you wrote to begin with??

Anyway, I have poked, prodded, searched here-there-and-everywhere, and I still cant find any reason or help about why My threads are only going one reply deep...
example...

this is how it should look (have another board to look at as an example)

original post
--------| first reply
--------------|reply to first reply
---------------------|reply to first reply's reply

but this is whats happening...

original post
--------| first reply
--------|reply to first reply
--------|reply to first reply's reply


if anyone could think of why this is doing this in phorum version: 3.2.11 , please enlighten me ;)

thanks so much for reading my rambles
Re: Target=Blank??
May 18, 2001 04:40PM
The threading is an option in the admin.

Brian.
Re: Target=Blank??
May 18, 2001 06:06PM
By George your right and i feel like a moron. I had changed so many settings and deleted/rebuilt my forums so many times that i forgot what settings i had. On the first try, i had them working correctly but after deleting and rebuilding them so many times , i got the settings screwed up on the last go around.

Thanks so much for your help, im finally done playing with it now i think, lol ;)

Appreciate it !!
Re: Target=Blank??
May 23, 2001 03:46PM
where can I find the hack for the new window?
Sham wrote:
>
> found the hack that worked for the new window deal, but still
> cant get the "email replies to this thread" thing to work or
> figure out why my phorum isnt threading third level replies...
>
>
> Any help would be greatly appreciated cause Im losing hair
> fast ;)
Re: Target=Blank??
May 23, 2001 09:27PM
Wow, I am on this replace plugin kick now. You just need to put a replace in the admin to replace <a with <a target="_blank".

Brian.
Re: Target=Blank??
May 25, 2001 07:24AM
other way to do it is to edit your read.php and find body_format function. inside there is replace for it.
Re: Target=Blank??
March 04, 2006 06:59AM
I just went into the BBCode Module file "mods/bbcode/bbcode.php" and changed the following two lines to include the Target=_bland command:

Quote

"[<a href=\"$1\" target=\"_blank\">$3</a>]",
"<a href=\"$1\" target=\"_blank\">$3</a>",
Re: Target=Blank??
March 04, 2006 02:11PM
thats phorum5, not phorum3 ;).
phorum-5.1 even has a simple module-setting for that.


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Sorry, you do not have permission to post/reply in this forum.