Firefox PHP

Use Phorum 5.0.17 with PHP < 4.3

Posted by barcino 
Use Phorum 5.0.17 with PHP < 4.3
August 24, 2005 04:27PM
as of Phorum 5.0.17 PHP >= 4.3 is needed because of:

2005-06-22 17:40 brian
* Support for more compact, single file modules
(from Changelog)

Function file_get_contents() in include/admin/mods.php, line 57 needs PHP 4.3...

The case is not tooo serious because only the Admin-Modules-Part is concerned, but if you want to add modules or config existing ones, you have a problem.

So if you are still running PHP < 4.3, as e.g. 4.2.2 as in RH 9.0, just put this line

continue;

right after line 55:

} elseif(is_file("./mods/$entry")){

Preferably add a comment concerning PHP version ;-)

This is a rather ugly way, surely one can do a better workaround and still use the "single file modules" feature... but at least the Admin-Module-Section will work the old way...
Re: Use Phorum 5.0.17 with PHP < 4.3
August 25, 2005 03:22AM
If we see a lot of reports about this, we may change it back.

Brian - Cowboy Ninja Coder - Personal Blog - Twitter
Sorry, only registered users may post in this forum.

Click here to login