Firefox PHP

polish_5.1.4

Posted by regdos.com 
All files from this thread

File Name File Size   Posted by Date  
polish-5.1.4.php 41.2 KB open | download regdos.com 11/27/2005 Read message
polish_5.1.4
November 05, 2005 04:28PM
Do wersji 5.1.4-alpha - Wersja dopracowana ju¿ raczej w 99,5%.
[edit - 2005.11.27] - nowa wersja pliku z poprawionymi literówkami, ortami i parê znaczeñ pozmienianych.

Jedyny mankament wynika z b³êdu na phorum - zreszt± juz zg³oszonego - z obs³ug± przez funkcje htmlentitles kodowania iso-8859-2.
¯eby poprawnie wy¶wietla³o polskie znaki oraz nie pojawia³ siê b³±d, w pliku jêzykowym ustawione jest:
$PHORUM["DATA"]['CHARSET']="iso-8859-1";
$PHORUM["DATA"]['LANG_META']="<meta http-equiv=\"Content-Type\" content=\"text/html; charset=iso-8859-2\" />";

a w pliku template header.tpl dwie pierwsze linie zast±piæ:
<?php header("Content-Type: text/html; charset=iso-8859-2") ?>
<?php echo '<?' ?>xml version="1.0" encoding="iso-8859-2"<?php echo '?>' ?>

Wszystko bêdzie poprawnie wy¶wietlane tylko w mailach bêd± krzaczki zamiast polskich liter. Miejmy nadzijê, ze deweloperzy phorum do¶æ szybko poprawi± to niedopatrzenie.

--
Tomasz Regdos :: www.regdos.com



Edited 4 time(s). Last edit at 11/27/2005 11:17PM by regdos.
Attachments:
open | download - polish-5.1.4.php (41.2 KB)
Re: polish_5.1.4
November 05, 2005 08:41PM
Uwielbiam Cie, bo od trzech tygodni nie moglem sie za to zabrac :D

Jedno co...

Warning: htmlentities(): charset `iso-8859-2' not supported, assuming iso-8859-1 in /home/domains/gniazdoswiatow.net/public_html/forum/list.php on line 366

Plus podobne w read.php :\

Dziwne.

___
Polskie Centrum WebKomiksu



Edited 2 time(s). Last edit at 11/05/2005 08:49PM by godai.
Re: polish_5.1.4
November 05, 2005 09:27PM
Quote
godai

Warning: htmlentities(): charset `iso-8859-2' not supported, assuming iso-8859-1 in /home/domains/gniazdoswiatow.net/public_html/forum/list.php on line 366

Plus podobne w read.php :\

Dziwne.

Niestey nie dziwne, funkcja htmlentitles nie operuje na tabeli naszego centralno europejskiego ISO, wiêc nadal jeste¶my skazani na krzaki w nag³ówkach i teraz tez charset jest wykorzystywany w szabonie.
Rowiazaneim jest przej¶cie na UTF-8 choæ to nie wiem jak z bazami danych itp. czy nie bêdzie problemu.
Drugim rozwiazaniem jest przepisanei funkcji htmlentitles na nowo z obs³uga naszego ISO i zg³osi³em to na tracku zobaczymy co developerzy powiedz±.

--
Tomasz Regdos :: www.regdos.com



Edited 2 time(s). Last edit at 11/05/2005 10:24PM by regdos.
Re: polish_5.1.4
November 07, 2005 09:49AM
Hm... Nowsze SQL chyba bez problemu, zreszta, mozna ustawic bezposrednio w bazie collations jako odpowiednie. Co nie zmienia faktu, ze przy przesiadce jest problem (to raz), a nie kazdy ma dostep bezposrednio do bazy (to 2). Pamietam, ze w moim SQL (4.1.10) musialem uzywac dodatkowej komendy w phorum 5.0.x ze wzgledu wlasnie na collations.


--- kod ---

function phorum_db_mysql_connect(){
$PHORUM = $GLOBALS["PHORUM"];

static $conn;
if (empty($conn)){
$conn = mysql_connect($PHORUM["DBCONFIG"]["server"], $PHORUM["DBCONFIG"]["user"], $PHORUM["DBCONFIG"]["password"], true);
mysql_select_db($PHORUM["DBCONFIG"]["name"], $conn);
}
mysql_query("SET collation_connection = @@collation_database;");
mysql_query("SET character_set_results = latin2;");
mysql_query("SET character_set_client = latin2;");
return $conn;
} 

--- kod ---

Jak widac, dopisywalo sie to przy polaczeniu do bazy. Nie mam pojecia - ty jestes magik, moze podpowie ci to jakies rozwiazanie...

Co ciekawe - (a troche bzdura) - uzywalem wersji 5.1.3 bodajze z plikiem jezyka wygenerowanym w adminie (tam jest taka dziwna funcja gdzies) - i nie zwracalo bledów; moze trze porównac naglówki oryginalnego pliku angielskiego do 5.1.x z tym twoim?

Moze zajrze do tego jak bede mial chwile dzis w pracy (padl mi domowy komp :\)

___
Polskie Centrum WebKomiksu
Re: polish_5.1.4
November 07, 2005 03:06PM
Quote
godai
Hm... Nowsze SQL chyba bez problemu, zreszta, mozna ustawic bezposrednio w bazie collations jako odpowiednie. Co nie zmienia faktu, ze przy przesiadce jest problem (to raz), a nie kazdy ma dostep bezposrednio do bazy (to 2). Pamietam, ze w moim SQL (4.1.10) musialem uzywac dodatkowej komendy w phorum 5.0.x ze wzgledu wlasnie na collations.
Tak tak s± z tym problemy ale to wynika ze sposobu kompilacja mysql-a i tego jak s± skompiowane bilblioteki z których korzysta potem php jakie¶ to zagwatmane pomimo, ze w configu mysql-a poustawia sie te wszystkie po³±czenia na latin2 to i tak w php trzeba przy ³±czeniu to wywo³ywaæ, choæ wystarczy 1 komenda zamiast 3.
Co do utf-a to ten problem ze ca³a strona musi byæ tak zakodowane i to w jakis sposób mo¿e sprawiaæ problem, ja moge przygotowac wersje napisó na utf-8 mo¿ ekomu¶ siê przyda.

Quote
godai
Jak widac, dopisywalo sie to przy polaczeniu do bazy. Nie mam pojecia - ty jestes magik, moze podpowie ci to jakies rozwiazanie...

Co ciekawe - (a troche bzdura) - uzywalem wersji 5.1.3 bodajze z plikiem jezyka wygenerowanym w adminie (tam jest taka dziwna funcja gdzies) - i nie zwracalo bledów; moze trze porównac naglówki oryginalnego pliku angielskiego do 5.1.x z tym twoim?

Generalnie istote problemu opisa³em w pierwszym moim po¶cie bo go wyedytowa³em i podmieni³êm napisy.
Jedynym rozs±dnym rozwi±zaniem jest naprawa tego b³êdu przez developerów, bo przeciêtny user chce sciagn±æ forum + plik jêzykowy i zapomnieæ o sprawie.
Sorry, only registered users may post in this forum.

Click here to login