Firefox PHP

Spatne kodovani ve foru s cestinou

Posted by gampik 
Spatne kodovani ve foru s cestinou
July 17, 2005 09:56AM
nedari se mne zprovoznit cestinu na svych strankach. ackoliv jsem ji vlozil do slozky /include/lang/ a vybral ji v nastaveni fora, php script stale generuje stranky s kodovanim iso-8859-1 , cimz se cestina mrsi. nevim, co s tim mam delat. poradite?
jak to vypada v praxi, je videt zde:
[www.gampik.net]

diky.
Re: Spatne kodovani ve foru s cestinou
July 18, 2005 11:22AM
Ještì navíc upravuju kódování v souboru header.tpl (adresáø template/default), napø. na

<?php echo '<?xml version="1.0" encoding="windows-1250"?>'; ?>

nebo podle volby. Na Vašich stránkách mají soubory kodování takto:

<?xml version="1.0" encoding="iso-8859-1"?>

Dál, jazykový soubor musí být samozøejmì zapsán ve vybraném kódování.
Zkuste, zda to pomùže?

Honza*), fórum o bylinkách a taky o křesťanském duchovním životě - [hoowoo.euweb.cz]
Re: Spatne kodovani ve foru s cestinou
July 18, 2005 12:36PM
dekuji. pomohlo to.
Re: Spatne kodovani ve foru s cestinou
July 19, 2005 11:31AM
Asi by se o tom mohli dozvìdìt i programátoøi fóra, píšou zøejmì v angliètinì, takže problém s kódováním nepoznají; není to poprvé, co si nìkdo na špatné kódování stìžuje.

I'd like to give a notice to Phorum dev's about probably a bug with a language encoding. I saw it in my phorum. This thread says the same and repeatedly I saw a complaint of it at non-English users too (where additional characters to English are used).

Bad encoding if a charset is set in language file only.

It gets right after the header.tpl file is modified - if you change the

<?xml version="1.0" encoding="iso-8859-1"?>

code with the right value you need.

But I did find any message about it nowhere. Maybe if a notice appears in the language file, such as
// to set the charset encoding you need modify the header.tpl file too
? It could help to many users:-)


Honza*), fórum o bylinkách a taky o křesťanském duchovním životě - [hoowoo.euweb.cz]
Re: Spatne kodovani ve foru s cestinou
July 19, 2005 11:37AM
in phorum-5.1 you can set that charset in the language-file already, its then used there for the htmlentities-calls too.


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Sorry, only registered users may post in this forum.

Click here to login