Firefox PHP
Re: User Avatar Module
October 17, 2007 08:24PM
<teaser>
I promise you that the version 3 of this module does work a lot more out-of-the-box than this one. Thomas and I did a full (backward compatible) rewrite of that module for Phorum 5.2 and it makes full use of all the new module coding possibilities that Phorum 5.2 offers. The only thing that you have to do with that version, is edit the template to put some code where you want the avatar to appear.
</teaser>


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: User Avatar Module
November 29, 2007 09:45AM
Hi, forum!

Here localization files for the Russian and Ukrainian languages
Attachments:
open | download - russian.php (1 KB)
open | download - ukrainian.php (1003 bytes)
Re: User Avatar Module
December 04, 2007 12:01PM
Quote
BritishV8
Has anyone gotten the 2.2.0 version of this mod to work in Phorum 5.1.25?

I'm new to PHP debugging, and this mod is giving me fits!

My server keeps logging an "unexpected T_IF" error in user_avatar.php along with a bunch of "unexpected character in input" warnings. The only thing fishy I see in user_avatar.php is that the last line appears to be missing. (There's no "?>" tag, but adding one didn't help.)

Another symptom is that the "settings" link in Admin (enabled after I turn the module on) ALWAYS brings a blank screen. I don't understand why. It's as if ./mods/user_avatar/settings.php were an empty file.

Any advice?

Yes, without problems. Just copy module as posted above and hack you template (or use predefined one).
Re: User Avatar Module
December 04, 2007 02:48PM
Hi,

thanks for this nice addon. Maybe anybody can help me a little bit. I get everything working, following the thread until here. But there is still one problem.

I can only change my avatar when I com e from "forum-list" -> Controll-center ->My image.

If I try it inside a forum it does not work. No Images are displayed. Any solution?

I use 5.1.25 and default template (little modifications).

Best wishes

Daniel
Re: User Avatar Module
December 04, 2007 03:49PM
Are you sure that its the "user-avatar"-module you are talking about? I think you used the avatar (3.0.0) from this thread [www.phorum.org] which is completely different module.


Thomas Seifert
Re: User Avatar Module
December 05, 2007 09:18AM
Quote
xdaniel
Hi,

thanks for this nice addon. Maybe anybody can help me a little bit. I get everything working, following the thread until here. But there is still one problem.

I can only change my avatar when I com e from "forum-list" -> Controll-center ->My image.

If I try it inside a forum it does not work. No Images are displayed. Any solution?

I use 5.1.25 and default template (little modifications).

Best wishes

Daniel

You have to hack your template. Read the included howto in readme.txt or use predefined template.
Re: User Avatar Module
December 06, 2007 02:55PM
Hi,

thanks for your answers. Yes I use this module in version 2.2. I tried the original themes and predefined templates and had the same problem.

Find enclosed two screenshots. The first one is if I enter the controlcenter from the frontpage. It works fine.

Same user reaches the controlcenter -> my image from inside a forum: no image to choose ...

Maybe anyone knows something about this.

Best wishes

Daniel


Sorry, only registered users may post in this forum.

Click here to login