Firefox PHP

Phorummail for Phorum 5

Posted by Brian Moon 
Re: Phorummail for Phorum 5
July 12, 2010 10:57PM
Thanks for the reply.

I saw that file however it is very old (older than the 5.2.15a release) and I also checked it: The problem is that the function phorum_user_check_field
(was in users.php) and possibly others are now not in the 5.2.15a code.

Any ideas?

Oliver



Edited 1 time(s). Last edit at 07/12/2010 10:58PM by fieldit.
Re: Phorummail for Phorum 5
July 13, 2010 09:01AM
check for replacing them with phorum_api_user... functions.
I think phorum_user_check_field is replaced by phorum_api_user_search with correct arguments.


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Phorummail for Phorum 5
July 27, 2010 11:41PM
That did the trick and its all working now.

Many thanks for your help.
Re: Phorummail for Phorum 5
August 17, 2010 01:36PM
Hello :)

Well, I know that this module is old and with External Phorummail exists an alternative. But so far I want to still use (old) Phorummail.

The problem is, that the module doesn't work when sending emails from certain addresses. I don't really know what distinguishes these addresses from others, but a consequence the sender receives an error message and the mail doesn't show up in the forum.

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

  pipe to |/bin/eximwrap xxxx 'ulimit -t 10 ;/usr/bin/php -q  /home/xxxx/public_html/forum/phorummail.php'
    generated by kontakt@xxxxx.xx

The following text was generated during the delivery attempt:

------ pipe to |/bin/eximwrap xxxx 'ulimit -t 10 ;/usr/bin/php -q  /home/xxxx/public_html/forum/phorummail.php'
       generated by kontakt@xxxxx.xx ------

    <html>
    <head><title>Phorum database error</title></head>
    <body>
    <h1>Phorum Database Error</h1>

    Sorry, a Phorum database error occurred.<br/>
    The error message has been written<br/>to the phorum-sql-errors.log error log.<br/>Please try again later!    </body>
    </html>
(I removed the following headers)

In phorum-sql-errors.log is this entry:
Time: 1282042548
Error: Illegal mix of collations (latin1_general_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '=' (1267): SELECT message_id
                FROM   zzf__messages
                WHERE  forum_id  = 22 AND
                       author    ='My Name' AND
                       subject   ='Just one row' AND
                       body      ='This is a short text' AND
                       datestamp > 1282038948
Back trace:
Function phorum_database_error called at
{path to Phorum}/include/db/mysql/mysqli.php:212
----
Function phorum_db_interact called at
{path to Phorum}/include/db/mysql.php:920
----
Function phorum_db_post_message called at
{path to Phorum}/phorummail.php:253
----

All tables of my database are latin1_general_ci and I'm using Phorum 5.2.15a.

Is there a solution for that problem?
Thanks in advance!

Greetings, Matze
Sorry, only registered users may post in this forum.

Click here to login