Firefox PHP

Group Auto-Email Module

Posted by Joe Curia 
Re: Group Auto-Email Module
September 06, 2007 11:15AM
Hi - me again,

I'm having a wee problem with this module - when a user selects 'No' to 'Enable automatic group emails:' in their profile and clicks submit, the message at the top of the page says 'Profile successfully updated.', but the select box still shows 'Yes'.

Does this have anything to do with the alts you helped me with earlier?

Regards,

David
Re: Group Auto-Email Module
September 06, 2007 11:17AM
Also, my client has asked if it would be possible to subscribe to receive notifications of new topics, instead of every individual post?

Regards,

David
Re: Group Auto-Email Module
September 06, 2007 03:05PM
David,

Looking through the mod files again I realized I hadn't added this to the installation directions:

In order for users to be able to turn off the automatic emails, you must create a custom profile field to store this data. In the Admin section, choose "Custom Profiles" from the menu. The new field name is "phorum_mod_group_autoemail_user_unsubscribe_setting" and it should have a field length of 3. You can leave "Disable HTML" checked. Click on "Add" and the field should show up in the list of custom profile fields.

Try that to see if it helps. I will look into the possiblity of the option to only receive new topics. I may also bring attachment sending to this version of the mod also.


Joe Curia (aka Azumandias)
Modules: l0Admin Mass Email00000000l000000Automatic Time Zones000ll.l00000Enhanced Custom Profiles0.00Google Calendar0000l.l000000Post Previews
000000000Admin Security Suite000000000000Check Modules for Upgrades0000External Authentication000000Group Auto-Email00000.00000Private Message Alerts
000000000Attachment Download Counter0000Custom Attachment Icons000ll.ll00Favorite Forums000000.00000Highlighted Search Terms0000Self-Delete Posts Option
000000000Attachment Watermarks0l00000000Custom Language Database00l.l.0Forum Lockdown00000.00000Ignore Forums0000000000000Threaded Tree View
000000000Automatic Message Pruning00.llll.00Easy Color Scheme Manager0l.l00Forum Subscriptions0000lll000Moderated User Group
Templates:lGeneric Integration000000000 0000Simple Rounded000000 00000000Tabbed Emerald
Re: Group Auto-Email Module
October 06, 2007 08:34PM
Strange, but it seems that something is wrong. At least i have no any new "field" in user's CC to switch off/on that feature. Module is activated, but no any chages at CC.

verison 5.2.1 alpha

Your fate is in your hands!
Re: Group Auto-Email Module
October 07, 2007 10:28AM
Do you have the hook "tpl_cc_usersettings" in your cc_usersettings.tpl template file? (you most probably have)
Did you enable "Allow users to choose to stop receiving group emails" in the module settings?

I think that are the two requirements for having the control center option show up. The option is added to the mail settings section of the control center.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce



Edited 1 time(s). Last edit at 10/07/2007 10:29AM by mmakaay.
Re: Group Auto-Email Module
October 07, 2007 10:37AM
Problem solved :)
1) switched to version for 5.2
2) logged in as non admin user :)
Re: Group Auto-Email Module
October 27, 2007 05:26AM
Pardon, but I'm a newbie. I transferred the module and enabled it through the 'Modules', however it doesn't seem to be working. When I click on the 'Settings' under the 'Yes' for enabled, I get a blank screen. Is this an indicator that I did something wrong?

Thanks for the module and also for this great forum. It's just what I was looking for.
Re: Group Auto-Email Module - German lang, spam problem
December 12, 2007 10:23PM
Hello,

Thanks for this mod, it works fine!

Here are the German language files:
german-sie.php:
<?php
$PHORUM["DATA"]["LANG"]["group_sub"]["NewMessage"] = "Thema:\n%subject%\n\nBeitrag:\n%plain_body%\n\nSehen Sie den gesamten Diskussionsstrang:\n%read_url%";
$PHORUM["DATA"]["LANG"]["group_sub"]["NewMessageSubject"] = "Neuer Beitrag in %forumname%";
?>
german-du-female.php and german-du-male.php:
<?php
$PHORUM["DATA"]["LANG"]["group_sub"]["NewMessage"] = "Thema:\n%subject%\n\nBeitrag:\n%plain_body%\n\nSiehe den gesamten Diskussionsstrang:\n%read_url%";
$PHORUM["DATA"]["LANG"]["group_sub"]["NewMessageSubject"] = "Neuer Beitrag in %forumname%";
?>

But there is a problem regarding to spam.
Since having installed Phorum 5.1.25 as a non-public forum (read-access only for registered users!) including the group auto-email mod, we - and all of our users! - get spam characterized by the following:
From is only -
Subject is empty
Body is empty, too
Header (= source code) is like the following (I have changed the mail address, IP, domain and user names):

From - Wed Dec 12 15:15:22 2007
X-UIDL: 1197468211.6746.mail4.ourreceivingmailserver.net,S=480
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
Return-Path: <ud00_000@mail.ourwebhostingprovider.de>
Delivered-To: me@example.com
Received: (qmail 6743 invoked by uid 89); 12 Dec 2007 14:03:31 -0000
Received: by simscan 1.3.1 ppid: 2349, pid: 2367, t: 120.4306s
scanners: attach: 1.3.1 clamav: 0.91.1/m:
Received: from unknown (HELO mail.ourwebhostingprovider.de) (194.000.000.00)
by 0 with SMTP; 12 Dec 2007 14:03:31 -0000
Received-SPF: none (0: domain at mail.ourwebhostingprovider.de does not designate permitted sender hosts)

How this can happen in a non-public forum? Is this a matter of the module? What can we do to protect our users from this spam? Thanks for advice!
Re: Group Auto-Email Module - German lang, spam problem
December 13, 2007 10:01AM
I don't think that an empty body and subject qualifies as spam.
you might want to debug all emails sent out by this module to find out if its sending wrong or too many mails.


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Group Auto-Email Module - German lang, spam problem
December 17, 2007 03:54PM
Hello,
if it's not spam, then it's junk data. First I have thought these mails may be the result of partially filtered spam attacks, but meanwhile there is an obvious relation to sending posts.
After posting the author is receiving up to 30 mails. Other users are receiving 2-6 mails. This is happening with some time lag, but it's always happening after posting.
Therefore we want to avoid this. Can you please tell me how to "debug all emails sent out by this module"? Are there other methods for limitation? Thanks!
Sorry, only registered users may post in this forum.

Click here to login