Firefox PHP

In-body attachment links/images (for Phorum 5.1 or later)

Posted by Maurice Makaay 
hjp
Re: In-body attachment links/images (for Phorum 5.1 or later)
February 17, 2007 09:26AM
Maurice, I know you´re just waiting for suggestions like this (chchhh :-)

Could it be possible to make mp3-files running with a small flash-player, if they are inline-attached?

<object type="application/x-shockwave-flash" data="dewplayer.swf?son=myfile.mp3" width="200" height="20">  </object>

can´t upload swf, here´s a link (it´s french) [www.estvideo.com]



Edited 1 time(s). Last edit at 02/17/2007 10:10AM by hjp.
Re: In-body attachment links/images (for Phorum 5.1 or later)
February 18, 2007 12:29AM
I have been looking for something like this a while ago, but I couldn't find a goot flash player. I found a couple which were way too big or which were licensed in a Phorum incompatible way. Since I run a guitarists website, having an MP3 player at hand is very welcome. So I'll certainly look into implementing this one. Thanks!


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
hjp
Re: In-body attachment links/images (for Phorum 5.1 or later)
February 19, 2007 06:16PM
Thanks in advance, Maurice. Dewplayer is both free and small, afaik.
Re: In-body attachment links/images (for Phorum 5.1 or later)
March 08, 2007 02:14PM
I tried something with dewplayer and allthough it's a nice player, I don't want to use it directly for playing the MP3 files. The reason for this, is that dewplayer will start downloading the MP3 immediately. On threads with a lot of MP3's, that's not really desired behavior. I only want to play the MP3 that the user selects. One idea might be to use some javascript to create the player object in a hidden div and turn on dewplayer with autoplay. Not really nice for dewplayer that way though, since it's not visible.

New version

I uploaded my latest version of the module (3.1.7) to the first message of this thread. I was a bit behind in publishing (it was at 3.1.2) because there are some related changes which I first wanted to testrun on my own site. See the changelog in the first message for full details of the changes that were made.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: In-body attachment links/images (for Phorum 5.1 or later)
March 09, 2007 04:16PM
here's another place for info on embeded players.. it's very helpful:

[klaus.geekserver.net]
Re: In-body attachment links/images (for Phorum 5.1 or later)
April 20, 2007 06:42PM
I released version 1.3.8 of the module (see the first message in this thread). This version contains a fix for a PHP warning about getimagesize(). If you sometimes see these warnings appear, then this new version will fix it.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: In-body attachment links/images (for Phorum 5.1 or later)
May 10, 2007 01:55PM
Hi,

I've installed the latest version of this mod, I'm using phorum 5.1.22. It works fine, except for the width limit. I've tried various settings and my large images come out full size. I'm uploading the photos using my control center and adding the url's via the image url button of the editors tools.
Re: In-body attachment links/images (for Phorum 5.1 or later)
May 10, 2007 02:04PM
From the README:
Troubleshooting:
----------------

If you have enabled scaling down of bbcode  tags,
but it is not working, check the following:

- Are the GD tools for PHP available on your system?

- Is the PHP configuration option "allow_url_fopen" enabled?

- Is it working if you (temporarily) disable the bbcode module?
  If this is the case, then the bbcode module is running its formatting
  code before this module does. In Phorum 5.2, this problem will be
  fixed by module priorities. For Phorum 5.1, you can fix it by
  installing a small module that will make bbcode the last formatting
  module. You can download this mod from the following URL:
  [www.phorum.org]

These are all the reasons that I know for
Re: In-body attachment links/images (for Phorum 5.1 or later)
June 12, 2007 06:35PM
Thanks for the mod, Maurice, it works great :)
Re: In-body attachment links/images (for Phorum 5.1 or later)
July 26, 2007 03:35PM
hello,



I've upgraded my phorum version en then the mod stop running in the database the message number isn't stored in the db.
I've downgrade phorum to 5.1.22 and the mod run wherywell.

so is this mod still runing with the lastest stable release ?

thanks for answer
Sorry, only registered users may post in this forum.

Click here to login