Firefox PHP

search function not working with two words

Posted by didi2 
search function not working with two words
March 05, 2010 11:59AM
Hello

We upgraded from an earlier phorum version and now we realised that the search function is only working with one word.

When I enter two words seperately, nothing is found.

Also when I want to use the search advanced and search for two words with the setting "any words", it just doesnt work.

I already updated the search index via admin tools.

I read somewhere that my SQL settings could be the problem. Could anyone explain in detail how I can fix that?

Thank you very much.

technical:
I tried this now with a complete clean install of the version 5.2.14 using the original theme and the SQL database of my already running forum; It didnt work. So I guess its not a phorum software problem. But I would be glad if anyone could help here.



Edited 1 time(s). Last edit at 03/05/2010 12:28PM by didi2.
Re: search function not working with two words
March 05, 2010 12:31PM
URL? MySQL Version? Which words for example?


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: search function not working with two words
March 08, 2010 08:39AM
Hello thomas

Thanky you for your reply.

The web adress is [www.still-dancing.com]
But as I wrote, it didnt work with classic theme either.

Also when I search for example for the single word "children" this thread doesnt show up.
[www.still-dancing.com]

Apache Server, 5.2.5 php and 5.0.67-community SQL version and MySQL-Client-Version: 4.1.22

best regards, dietmar



Edited 1 time(s). Last edit at 03/08/2010 10:56AM by didi2.
Re: search function not working with two words
March 08, 2010 01:09PM
As for the single word, that thread is over a year old, so you need to go into the advanced search and search for all dates (default is within the past year).

Searching here on Phorum found this thread which may help: [www.phorum.org]

Seems the answer there was to set mysql_use_ft => 1 in the config.php file.


Joe Curia (aka Azumandias)
Modules: l0Admin Mass Email00000000l000000Automatic Time Zones000ll.l00000Enhanced Custom Profiles0.00Google Calendar0000l.l000000Post Previews
000000000Admin Security Suite000000000000Check Modules for Upgrades0000External Authentication000000Group Auto-Email00000.00000Private Message Alerts
000000000Attachment Download Counter0000Custom Attachment Icons000ll.ll00Favorite Forums000000.00000Highlighted Search Terms0000Self-Delete Posts Option
000000000Attachment Watermarks0l00000000Custom Language Database00l.l.0Forum Lockdown00000.00000Ignore Forums0000000000000Threaded Tree View
000000000Automatic Message Pruning00.llll.00Easy Color Scheme Manager0l.l00Forum Subscriptions0000lll000Moderated User Group
Templates:lGeneric Integration000000000 0000Simple Rounded000000 00000000Tabbed Emerald
Re: search function not working with two words
March 08, 2010 02:52PM
Thank you. Problem solved.
Sorry, only registered users may post in this forum.

Click here to login