Firefox PHP

Updated and got an error message

Posted by contractor 
Updated and got an error message
September 20, 2007 01:33AM
I updated to the newest version. I did this twice using two different names for the phorum folder, phorum and phorum2. I did the second update first to see if it would work before updating my larger one. It worked fine and still does.

The one I call phorum however gave me an error code during the upload as follows.

--------------------

Upgrading from patch level 2007050603 to 2007050900 ...
An error occured during this upgrade:

Unknown column 'from_user_id' in 'phorum_pm_messages'

================

Still, it worked ok for a while. Then I added the mod for in line images. That worked fine. Then I added the mod for user avatars. I changed the code in the listed tpl files and uploaded them. But now I get this error on my message board.

Phorum Database Error

Sorry, a Phorum database error occurred.
Please try again later!
Error:

Column 'forum_id' in field list is ambiguous (1052): select forum_id, count(*) as count from phorum_user_newflags inner join phorum_messages using (message_id, forum_id) where phorum_user_newflags.user_id=1 and parent_id=0 and forum_id in (1,3,4,5,21,9,6,7,10,2,8,22,15,16,13,18,14,17,12,11,23) group by forum_id
Backtrace:

Function phorum_database_error called at
{path to Phorum}/include/db/mysql/mysql.php:158
----
Function phorum_db_interact called at
{path to Phorum}/include/db/mysql.php:4663
----
Function phorum_db_newflag_count called at
{path to Phorum}/include/index_classic.php:34
----
Function include_once called at
{path to Phorum}/index.php:76
----


So where do I begin or do I delete the entire thing and start over?

Thanks
Re: Updated and got an error message
September 20, 2007 09:06AM
the error message tells that you upgraded to the latest development version.
Its the same error-message like described and replied to here already [www.phorum.org] .


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Updated and got an error message
September 20, 2007 03:31PM
You're right. For some reason I just figured Godaddy would be more up to date. Guess that's why they're so cheap.
Sorry, only registered users may post in this forum.

Click here to login