Firefox PHP

Getting a blank page on an upgraded Phorum

Posted by henny 
Getting a blank page on an upgraded Phorum
September 06, 2011 04:51AM
Hi,

I have used a phorum for my students already for quite some while. Originally it was in Korean but since there are no language files anymore I changed it to English. However I haven't used it for quite a while (nor did my students) and now when I try to take a look at it I understand why. All it gives is a blank page. When I try to go the admin page, I can login but after that I get a blank page as well.

When I look at the log files I see the following (don't have that kind of problems with other phorums on the same server though)

[Tue Sep 06 04:31:19 2011] [error] [client 58.123.210.146] PHP Warning: is_dir() [<a href='function.is-dir'>function.is-dir</a>]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/storage/vhosts/student.henny-savenije.pe.kr/httpdocs/:/tmp/) in /storage/vhosts/student.henny-savenije.pe.kr/httpdocs/phorum-5.2.11/include/cache/file.php on line 209, referer: [www.student.henny-savenije.pe.kr]
[Tue Sep 06 04:31:19 2011] [error] [client 58.123.210.146] PHP Warning: is_dir() [<a href='function.is-dir'>function.is-dir</a>]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/storage/vhosts/student.henny-savenije.pe.kr/httpdocs/:/tmp/) in /storage/vhosts/student.henny-savenije.pe.kr/httpdocs/phorum-5.2.11/include/cache/file.php on line 209, referer: [www.student.henny-savenije.pe.kr]
[Tue Sep 06 04:31:19 2011] [error] [client 58.123.210.146] PHP Warning: is_dir() [<a href='function.is-dir'>function.is-dir</a>]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/storage/vhosts/student.henny-savenije.pe.kr/httpdocs/:/tmp/) in /storage/vhosts/student.henny-savenije.pe.kr/httpdocs/phorum-5.2.11/include/cache/file.php on line 209, referer: [www.student.henny-savenije.pe.kr]
[Tue Sep 06 04:31:25 2011] [error] [client 58.123.210.146] ModSecurity: Audit log: Failed to create subdirectories: /var/asl/data/audit/20110906/20110906-0431 (Permission denied) [hostname "www.student.henny-savenije.pe.kr"] [uri "/phorum-5.2.11/index.php"] [unique_id "TmWF-X8AAAEAADZEdwYAAAAI"]

Any help is appreciated.
Re: Getting a blank page on an upgraded Phorum
September 06, 2011 01:12PM
There's all kind of stuff going on that isn't directly Phorum related. Are you administering this machine yourself or is it hosted with a company? In that last case, it might be best to contact that company for help.

Both issues (open_basedir config in PHP and ModSecurity config in Apache) must be fixed by configuring the host correcty.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Sorry, only registered users may post in this forum.

Click here to login