Firefox PHP

Can't log-in to Phorum Admin

Posted by dlc3172 
Can't log-in to Phorum Admin
October 25, 2007 03:09AM
When I enter my username and password, the page just reloads with the username/password prompt again. Not even a message saying "wrong password" or something. I know I'm doing something stupid....I just can't figure it out!
Re: Can't log-in to Phorum Admin
October 25, 2007 03:46AM
It mean you are still entering wrong username or password or you managed to removed admin status from your account by accident that it no longer think it have admin access.

The admin page will not tell you if the username or password is wrong and that is intended, no need to tell the hacker how close he is being right to accessing the admin page.

Bill
Re: Can't log-in to Phorum Admin
October 25, 2007 08:31AM
or you are not accepting cookies from that domain as the admin needs cookies to work.


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Can't log-in to Phorum Admin
October 25, 2007 07:24PM
I know I'm entering the correct username and password.

How can I fix the admin status?
Re: Can't log-in to Phorum Admin
October 25, 2007 08:39PM
The only thing that is needed for an administrator is that the "admin" field in the database is set to "1". So check if that is the case. I wrote a little script once for recovering / setting the admin status for a user. You can edit that script, put it in the Phorum install directory and run it from your browser (especially useful if you don't have a good database access to check the admin field yourself). The script can be downloaded from here: [secretsauce.phorum.org] (make sure to rename it to rescue_admin.php).

If the admin field is set correctly to 1, then maybe your password was changed? In that case, you could put in a new MD5 hashes password in your user record. An even easier way could be to tell Phorum at the login screen that you lost your password. Then you will be able to recover it through the standard password recovery procedure (by mail).


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Can't log-in to Phorum Admin
October 26, 2007 12:06AM
I'm using phpMyAdmin. This is what it looks like:


Field Type Collation Attributes Null Default Extra Action

admin tinyint(1) No 1


Default was 0 and I changed it to 1. Is that correct? If so, I still can't log-in. I requested a new password, and then changed it to my usual. It still won't let me log in to the Admin.php

Sorry for the trouble...I'm not a programmer or anything close to one.
Re: Can't log-in to Phorum Admin
October 26, 2007 03:06PM
The admin field should be set to 1 indeed. Maybe you could try cleaning out the cookies in your browser, to make sure there's no conflicting cookie in there? There is really not much to enable the login, so it's hard to guess what's going on.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Can't log-in to Phorum Admin
October 26, 2007 11:18PM
Clearing cookies didn't work.

When I type in my username and password, what is admin.php checking that against? Should I look there to make sure that the username and password is what I think it is?
Re: Can't log-in to Phorum Admin
October 26, 2007 11:24PM
the users table (phorum_users probably). The fields are username and password. password is an md5(hash) of the password.

Brian - Cowboy Ninja Coder - Personal Blog - Twitter
Re: Can't log-in to Phorum Admin
October 26, 2007 11:36PM
I also had this problem with my original install.

1. I had screwed up my cookies (discovered by accessing in FireFox having NEVER been to this domain before).
Cleared cookies in IE -- CLOSED BROWSER completely -- Restarted -- no more problem.

2. Upon registering a test version of myself (for the very first time on Phorum ever) I didn't realize that I would need to authenticate the registration by reading my email first (forgot I checked that box).

After that, no problems at all.
Re: Can't log-in to Phorum Admin
October 27, 2007 06:13AM
Nothing seems to work. I guess I'll just have to reinstall the whole thing, which I really don't want to do because I customized some of the files

Seems like there should be an easier solution to this..
Re: Can't log-in to Phorum Admin
October 27, 2007 11:16AM
you hacked the core files? then you might have done something wrong there.
If its just templates then you can copy them other but I doubt that a new install will do you any good.
could you check in e.g. firefox if there is a cookie send to you on admin-logon and what its content is?


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Can't log-in to Phorum Admin
October 27, 2007 08:12PM
no, just templates.

I'm not using firefox
Re: Can't log-in to Phorum Admin
October 27, 2007 08:16PM
I'm pretty sure that other browser have the same functionality, to show the cookie-content and get an alert if a cookie is sent and which one.


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Can't log-in to Phorum Admin
October 27, 2007 10:12PM
I just reinstalled and I can log in again
Re: Can't log-in to Phorum Admin
January 28, 2008 12:26PM
I'm having the same problem here,

admin = 1
password is correct

cookies deleted, Admin still won't get access.

I had the problem before but when using ctrl+F5 it reloads and shows the admin panel, but now nothing works,

I'm using the embed module with drupal and the forum itself works perfectly, but to the admin panel I can't get access.

I even turned of rewrite rules on the server, it still doesn't work

any info everyone?

Tino
Re: Can't log-in to Phorum Admin
January 28, 2008 12:48PM
Is there also a value set in the password field and is that the correct MD5 sum for your administrator password? For all other users, the password can be empty in the database, but the admin user needs a password in the Phorum database.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Can't log-in to Phorum Admin
January 29, 2008 09:12AM
Hi Maurice,

yes correct MD5 sum is in there. It's the exact same as in the drupal user table. And login to drupal works perfectly using the admin password.

Tino
Re: Can't log-in to Phorum Admin
January 29, 2008 09:26AM
All seems to be in place:

- cookies enabled in browser
- no broken cookies in the way
- user has admin = 1
- user has an MD5 hashed password in the password field

Some more things to check:

- The value of the "active" field for that user, which should be set to 1
- whether the password is really plain MD5 (check using <?php print md5('yourpass') ?>)


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Can't log-in to Phorum Admin
January 29, 2008 12:11PM
I just checked everything and all the points you mention are working the way they should.

Could the database colation and charset have something to do with this?? I was having and still have minor problems with the database of phorum and drupal and UTF8,

some characters still display the <?> in Phorum instead of the special character,
I think the data in the phorum database is not completely set to utf-8,

Just thinking if it might had anything to do with it??

The login an synchronization of drupal and phorum works seemlessly. I can login as admin and have all rights within the phorum community, however the admin panel doesn't let me in.

Tino

Quote
mmakaay
All seems to be in place:

- cookies enabled in browser
- no broken cookies in the way
- user has admin = 1
- user has an MD5 hashed password in the password field

Some more things to check:

- The value of the "active" field for that user, which should be set to 1
- whether the password is really plain MD5 (check using <?php print md5('yourpass') ?>)
Re: Can't log-in to Phorum Admin
January 29, 2008 12:38PM
I really don't have ammunition left for this one. All seems okay from what you tell me. I don't know of any other things that are needed for the admin interface login. Can you try if you can login if you temporarily disable the embedding module by moving the mods/embed_phorum directory to mods/embed_phorum-DISABLED or so?

I'm afraid that finding out what is causing your problem will take some tracing through the code to find the hurting spot.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Can't log-in to Phorum Admin
January 29, 2008 01:47PM
Maurice I just did that but no luck either.

Is there a way to easyily reinstall the admin interface or the whole phorum without losing any data and settings?

Tino

Quote
mmakaay
I really don't have ammunition left for this one. All seems okay from what you tell me. I don't know of any other things that are needed for the admin interface login. Can you try if you can login if you temporarily disable the embedding module by moving the mods/embed_phorum directory to mods/embed_phorum-DISABLED or so?

I'm afraid that finding out what is causing your problem will take some tracing through the code to find the hurting spot.
Re: Can't log-in to Phorum Admin
January 29, 2008 02:57PM
You could try installing phorum in a directory next to your current one. No problem with that as far as the admin interface is concerned. Unpack the tree, copy your include/db/config.php and you're done. The installer won't be run when doing this. The only thing that will be set incorrectly is the http_path, so browsing through the front end might give some unexpected results (because URLs will point to the original http path). The admin interface however should be accessible in this setup. So, you could try to follow this path to see if the problem lies in the code or in the database.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Can't log-in to Phorum Admin
January 30, 2008 10:09AM
Maurice thanks I will try this once I have a moment time.

thanks a lot for your help
Tino

Quote
mmakaay
You could try installing phorum in a directory next to your current one. No problem with that as far as the admin interface is concerned. Unpack the tree, copy your include/db/config.php and you're done. The installer won't be run when doing this. The only thing that will be set incorrectly is the http_path, so browsing through the front end might give some unexpected results (because URLs will point to the original http path). The admin interface however should be accessible in this setup. So, you could try to follow this path to see if the problem lies in the code or in the database.
Re: Can't log-in to Phorum Admin
February 12, 2008 10:34AM
Maurice I just installed phorum into a directory next to the original one and copied the config file like you suggested,
however I get the same problem as in the original admin panel. I just can't login. The admin login shows up fine but when trying to login, nothing. Just the same login screen over and over again no matter what browser or settings I use.


So I guess it must be a problem in my database?

Tino
Re: Can't log-in to Phorum Admin
February 12, 2008 10:43AM
Please put a different prefix in the config.php for the new phorum tree. That will start an installation, creating new tables with the new prefix (so you can easily delete the tables for this test afterwards). I'm wondering if you can login a fresh installed Phorum. If you can, then the problem is in your database that you are currently using. It could be useful to compare the admin user record from the old and the new db in this case.


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce
Re: Can't log-in to Phorum Admin
February 12, 2008 11:07AM
new phorum created and login works fine. I have to reload FF manually after login so the admin panel shows but I had that problem in FF before.

In IE it works perfect.

I also can't find any major difference in the user table

????

Tino
Re: Can't log-in to Phorum Admin
February 12, 2008 11:17AM
That reloading part is strange. I never have to do that in any of my browsers.

No major differences. What are the differences? Can you show use the two admin user records from both user tables? Empty out the password fields when doing this.

BTW: what Phorum version are you running?


Maurice Makaay
Phorum Development Team
my blog linkedin profile secret sauce



Edited 1 time(s). Last edit at 02/12/2008 11:19AM by mmakaay.
Re: Can't log-in to Phorum Admin
February 12, 2008 11:18AM
settings, especially use_cookies and session-settings are interesting too (even though they should have no influence).


Thomas Seifert
Phorum Development Team / Mysnip-Solutions.de
Custom Phorum and general software development
worry-free Phorum Hosting
Re: Can't log-in to Phorum Admin
February 12, 2008 11:23AM
Hi Maurice,

ok here's what I just did:

I exported the original user table and inserted into the new phorum installation. The result the admin login there now also no longer works.

here are the 2 rows for admin of the original and new install (passwords marked out):

original:
(`user_id`, `username`, `password`, `cookie_sessid_lt`, `sessid_st`, `sessid_st_timeout`, `password_temp`, `email`, `email_temp`, `hide_email`, `active`, `user_data`, `signature`, `threaded_list`, `posts`, `admin`, `threaded_read`, `date_added`, `date_last_active`, `last_active_forum`, `hide_activity`, `show_signature`, `email_notify`, `pm_email_notify`, `tz_offset`, `is_dst`, `user_language`, `user_template`, `moderator_data`, `moderation_email`) 
(1, ' Admin', '***', 'embed_1_2c7b4d89367a3356142754be139ddfb9', 'embed_1_2c7b4d89367a3356142754be139ddfb9', 0, '***', ' info@hummer-2-rent.de', '', 0, 1, '', ' Beste Grüße\r\nCarsten Rakus\r\nwww.hummer-group.com\r\nwww.hummer-advertisement.com\r\nwww.hummer-2-rent.com\r\nwww.hummer-merchandize.com\r\nwww.hummer-zone.com', 0, 254, 1, 0, 1163703431, 1202723247, 0, 0, 0, 0, 0, -99, 0, '', '', '', 1),

new:
(`user_id`, `username`, `password`, `cookie_sessid_lt`, `sessid_st`, `sessid_st_timeout`, `password_temp`, `email`, `email_temp`, `hide_email`, `active`, `user_data`, `signature`, `threaded_list`, `posts`, `admin`, `threaded_read`, `date_added`, `date_last_active`, `last_active_forum`, `hide_activity`, `show_signature`, `email_notify`, `pm_email_notify`, `tz_offset`, `is_dst`, `user_language`, `user_template`, `moderator_data`, `moderation_email`)
(1, 'Admin', '***', '7053a5959bba2881fcc2036dd3aaa764', '', 0, '***', 'tino@tino-designs.com', '', 0, 1, NULL, NULL, 0, 0, 1, 0, 1202810619, 1202810619, 0, 0, 0, 0, 1, -99, 0, '', '', NULL, 1);



Edited 1 time(s). Last edit at 02/12/2008 11:24AM by DonTino.
Sorry, only registered users may post in this forum.

Click here to login